Please note that User Registration has been temporarily disabled due to a recent increase in automated registrations. If anyone needs an account, please request one here: RequestAccount. Thanks for your patience!--Wmat (talk)
Please email User:Wmat if you experience any issues with the Request Account form.

Difference between revisions of "CT-PC89E Bugs"

From eLinux.org
Jump to: navigation, search
(Bugs found with operating the CT-PC89E)
(21mar2010 report from fjp)
Line 28: Line 28:
 
overall: good!
 
overall: good!
  
 +
* osx-style rollerbar at bottom did not start up on first boot.
 
* mouse trackpad was inoperable when machine started up when low on battery.  inserting power cable, mouse trackpad was fine.
 
* mouse trackpad was inoperable when machine started up when low on battery.  inserting power cable, mouse trackpad was fine.
 
* was unable to connect to my IMAP server; AFAICT no SSL support
 
* was unable to connect to my IMAP server; AFAICT no SSL support

Revision as of 21:24, 2 March 2010

Bugs found with operating the CT-PC89E

This page contains a record of problems found so far with the CT-PC89E, a very new design of ARM 8.9in netbook. As they are corrected, the issues will be removed.

  • Starting "appliaction" spelling mistake
  • Plastic button activiating Reset pushed in (!) after use only about ten times. still works but care now needed.
  • No lid "sleep" system, so LCD stays active after lid is closed
  • machine left on overnight resulted in "LCD burn" probably due to kernel crash resulted in brightness of LCD being pushed beyond limits (a common problem on embedded systems). can only really be fixed by a hardware watchdog timer, resulting in power-down.
  • layout of filesystem is not FHS compliant.
  • kernel modules have been moved to /drivers instead of /usr/lib/modules/2.6.24.2/kernel/drivers
  • debian packages on MOS mid-fun operating system violate FHS and standard debian policy: many packages install identical files TWICE, some of which are in an indentical file-structure under /READONLY_FS.
  • kernel modules compiled into the kernel are still present in /drivers, causing segfaults in some cases
  • kernel GPL source code not yet been provided
  • u-boot GPL source code not yet been provided
  • MOS mid-fun GPL source code not yet been provided (workaround provided by creating a Debian/Lenny image)
  • on 3G dialup (vodafone USB modem), pppd segfaults (presumably kernel problem) under Debian, and machine becomes unreliable (indicating kernel problem).
  • on 3G dialup (USB modem used by adam), again it fails. kernel source DEFINITELY needed.
  • root password was cracked within 4 days, by running "john" on /etc/passwd, and found to be "mos2010"
  • /etc and many other files are owned by midfun not root, making it unnecessary to have performed the crack: just edit /etc/passwd
  • /sbin/udevd and other applications run as root are owned by midfun, allowing them to be replaced and perform root operations under user control.
  • screen brightness control is non-linux-compliant: there is no standard entry (that could be found) in /proc or /sys for the LCD brightness, making it impossible to use standard linux applications and distributions.
  • the built-in microphone doesn't seem to work, or if it does, the kernel drivers are borked and don't make it available under ACPI. speakers work fine though.
  • The newly-developed http://gitorious.org/xf86-video-s3c64xx which is 20x or greater speedups cannot be used because the linux kernel source is not yet available.
  • removing ethernet cable, re-insertion doesn't result in reconnection

21mar2010 report from fjp

overall: good!

  • osx-style rollerbar at bottom did not start up on first boot.
  • mouse trackpad was inoperable when machine started up when low on battery. inserting power cable, mouse trackpad was fine.
  • was unable to connect to my IMAP server; AFAICT no SSL support
  • I played an AVI (a 2005 episode of Doctor Who) on it; fairly good, but not great; there were some freezes, probably due to buffer underruns
  • while playing the AVI with headphone plugged in there was a fairly loud hiss from the internal speaker
  • there seems to be some flash support: it loads, but when playing all I got was a "DEMO" logo instead of the actual content
  • Application manager allows to install some additional packages, but installation of gnome-games resulted in errors (unrecognized format of SVG files) when trying to play them. Missing dependency I guess.
  • Loads of funny spelling errors (to say nothing about some of the phrases):
    • - PowerManagaer
    • - PowerManager Eanble
    • - FALSH (instead of FLASH)