Please note that User Registration has been temporarily disabled due to a recent increase in automated registrations. If anyone needs an account, please request one here: RequestAccount. Thanks for your patience!--Wmat (talk)
Please email User:Wmat if you experience any issues with the Request Account form.

Difference between revisions of "Extension:ParserFunctions"

From eLinux.org
Jump to: navigation, search
(Installation: Make sure people get the right version)
 
m (1 revision: Importing Help again, with additional pages.)
 
(No difference)

Latest revision as of 04:50, 28 January 2010

       
Manual on MediaWiki Extensions
List of MediaWiki Extensions
Crystal Clear action run.png
ParserFunctions

Release status: stable

Implementation  Parser functions
Description Enhances parser with logical functions
Author(s)  Tim StarlingTalk
MediaWiki  1.7+
License GPL2 or Any OSI approved license
Download Download snapshot

Subversion [Help]
Browse source code

check usage (experimental)

ParserFunctions extension enhances parser with logical functions. New versions (r50997+) also incorporate the features of StringFunctions. For instructions on how to use it, please see the help page.

Installation

  1. Download a snapshot and extract it to your extensions directory. Choose the version that matches your version of MediaWiki.
  2. Add
    require_once( "$IP/extensions/ParserFunctions/ParserFunctions.php" );
    to the bottom of LocalSettings.php.
  3. If you want to use the integrated string function functionality, add $wgPFEnableStringFunctions = true; just after that.
  4. Installation can now be verified through Special:Version of your wiki.

Requirements

The ParserFunctions extension requires

  • MediaWiki 1.7.0 or above
  • PHP compiled with 'ctype' functions (almost always is included by default)

If you are using Mediawiki 1.7.1 you can download the ParserFunctions for version 1.10. Just follow the instructions mentioned above and everything works fine.

For MediaWiki 1.15.1, use the REL1_15_1 branch.

For the trunk version (currently 1.16alpha), use the trunk version.

See also

This extension is being used on one or more of Wikimedia's wikis. It means that the extension is stable and works well enough to be used by such high traffic websites. A full list of the extensions installed on a particular wiki is produced by Special:Version on that wiki.

Language: English