R-Pi Troubleshooting

From eLinux.org
Revision as of 16:20, 19 April 2012 by Linker3000 (Talk | contribs)

Jump to: navigation, search

Back to the Hub. This page lists the most common problems and suggests some solutions.

Power / Start-up

A good power supply that will supply 5V is vital. There is more information about power supplies and troubleshooting here http://elinux.org/RPi_Hardware#Power

Red power LED does not light, nothing on display

The power is not properly connected.

Red power LED is on, green LED does not flash, nothing on display

The Raspberry Pi cannot find a valid image on the SD card.

Raspberry Pi shuts down soon after booting up

This is caused by a power supply with too low voltage or too high voltage.

Keyboard / Mouse / Input Devices

Keyboard randomly repeats key presses

This is caused by inadequate power. Use a good power supply and a good power cable. Some USB devices require a lot of power, most will have the voltage and mAh on the back of them, they should be 5v 100mAh each max, any more than this they must be used with a powered USB hub. Try unplugging every USB device except the keyboard (you should also note that some keyboards have built in hubs and can try to draw 1500mAh (Pi can only handle 100mAh per USB slot without a hub)).

Memory Cards

General / Formatting

If you are having problems setting up your memory card you might want to try erasing it completely - especially if it has been used elsewhere and still contains data / partitions. Windows and Mac users can download a formatting tool from the SD Association: https://www.sdcard.org/downloads/formatter_3/

Networking

Ethernet connection is lost when a USB device is plugged in

This is caused by inadequate power. Use a good power supply and a good power cable. Some USB devices require a lot of power, so they must be used with a powered USB hub. Some cheap USB hubs suck power from the Raspberry Pi even if a USB power supply is connected.

Sound

Sound does not work

Device drivers for sound are still being developed. Please wait for the community to improve the situation.

Display

Video does not play or plays very slowly

Device drivers for video are still being developed. The XMBC distribution is the only distribution with good video support at the moment. Please wait for the community to improve the situation.

Can only get 800x480 resolution in LXDE (Arch linux)

Known issue with distro package as of 17-Apri-2012 - there's some missing boot config info. Creating a suitable cmdline.txt fixes it - type the following at the Raspberry Pi command line:

  sudo echo "dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 root=/dev/mmcblk0p2 rootfstype=ext3 rootwait" >/boot/cmdline.txt

GPIO