Difference between revisions of "Raspbian"

From eLinux.org
Jump to: navigation, search
m
m (Some copy editing.)
 
(9 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
[[Category:RaspberryPi]]
 
[[Category:RaspberryPi]]
  
Raspbian is a project to create a hard float port of debian for the [[Raspberry Pi]] and similar devices which use ARMv6 processors with VFPv2. The official Debian armhf packages are built with ARMv7, VFPv3_D16 and Thumb2. So they are not suitable for the Pi and similar devices. To get round this we have to change the compiler defaults (easy) and recompile everything (harder than it sounds).
+
Raspbian is a project to create a hard float port of Debian for the [[Raspberry Pi]] and similar devices which use ARMv6 processors with VFPv2. The official Debian armhf packages are built with ARMv7, VFPv3_D16 and Thumb2. So they are not suitable for the Raspberry Pi and similar devices. To get round this we have to change the compiler defaults (easy) and recompile everything (harder than it sounds).
  
Infrastructure has been set-up for building packages. We aim to stay as close to Debian wheezy as possible but we will pull in packages from sid and/or make our own modifications when we deem it necessary.
+
Infrastructure has been set-up for building packages. We aim to stay as close to Debian 7 (Wheezy) as possible, but we will pull in packages from sid and/or make our own modifications when we deem it necessary.
  
A chroot can be bootstrapped from a Debian squeeze armel installation using the following commands (replace /chroots/wheezy-armhf-rpi with where you want your chroot).
+
A chroot can be bootstrapped from a Debian 6.0 (Squeeze) armel installation using the following commands (replace /chroots/wheezy-armhf-rpi with where you want your chroot).
  
 
<pre>
 
<pre>
Line 20: Line 20:
  
 
Since this is running in a chroot you probably don't want it attempting to start and stop services when you update packages. To avoid this create a file /usr/sbin/policy-rc.d
 
Since this is running in a chroot you probably don't want it attempting to start and stop services when you update packages. To avoid this create a file /usr/sbin/policy-rc.d
with the following commands
+
with the following commands.
 
<pre>
 
<pre>
 
cat << EOD >/usr/sbin/policy-rc.d
 
cat << EOD >/usr/sbin/policy-rc.d
Line 29: Line 29:
 
chmod 0755 /usr/sbin/policy-rc.d
 
chmod 0755 /usr/sbin/policy-rc.d
 
</pre>
 
</pre>
 +
 +
==Create your own Raspbian Image==
 +
 +
*HowTo Create your own Raspbian Image (German) http://raspberry.tips/raspberrypi-tutorials/eigenes-raspbian-image-fuer-den-raspberry-pi-erstellen/
  
 
==Modified packages==
 
==Modified packages==
Line 40: Line 44:
 
!Notes
 
!Notes
 
|-
 
|-
| elfutils
+
| abiword
| testsuite disabled
+
| remove build-depends on valgrind
| testsuite failed on plugwash's build system and package was needed
+
| We didn't have Valgrind in Raspbian at the time and abiword doesn't really need it (it's only used to run build-time tests)
| local hack, hopefully we can drop later.
+
| We now have a working Valgrind, so this should be dropped the next time the package is updated.
 
|
 
|
 
|-
 
|-
| rowspan | gcc-4.6
+
| apparmor
| change compiler defaults
+
| add build-depends on gcc-4.7
| need to build binaries suitable for rpi
+
| The package was trying to build Perl-related stuff with gcc-4.7 due to changes we made in the Perl packaging.
| permanent raspbian change, not suitable for pushing upstream
+
| It is now dealt with on the Perl side. The change to be dropped next time a new version comes in.
 +
|
 +
|-
 +
| apt
 +
| Change dependency from debian-archive-keyring to raspbian-archive-keyring
 +
| We don't want Raspbian users to have the Debian archive keyring and we do want them to have the Debian one.
 +
| Permanent Raspbian change
 +
|
 +
|-
 +
| ceph
 +
| disable use of libatomic-ops
 +
| libatomic-ops and ceph don't seem to work together on plain armv6
 +
| Most likely permanent Raspbian change
 +
|
 +
|-
 +
| rowspan=3 | chromium-browser
 +
| Set v8 settings for armv6 in debian/rules (based on work by Florian Will)
 +
| rowspan=2 | raspbian is built for armv6
 +
| rowspan=2 | most likely permanent Raspbian change
 +
| rowspan=3 | build memory and address space use is a massive PITA
 +
|-
 +
| Fix build settings for embedded ffmpeg to produce armv6 code
 +
|-
 +
| Build with bfd instead of gold
 +
| Avoid segfault on startup
 +
| Discussed in Debian bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=696909 696909], not applied in Debian yet due to other problems.
 +
|-
 +
| rowspan=3 | clisp
 +
| Add armhf to architecture lists
 +
| armhf was not in architecture lists and package was requested by user
 +
| rowspan=2 | bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=684631 684631] filed in debian.
 +
|
 +
|-
 +
| Apply patch from SourceForge to fix operation on modern ARM
 +
| Package failed to build with illegal instruction error while running newly built clisp binary.
 +
|
 +
|-
 +
| Build with gcc-4.7
 +
| Build failed with ICE
 +
| Local change likely to be kept until Debian makes 4.7 the default on armhf
 +
|
 +
|-
 +
| clucene-core-experimental
 +
| Raspbian specific source package based on experimental version of clucene-core with renamed source package and dev package.
 +
| Experimental version of LibreOffice needed newer versions of libclucene than was present in Debian&nbsp;7 (Wheezy).
 +
| Local hack that hopefully can be dropped post-Wheezy
 +
|
 +
|-
 +
| rowspan=2 | eglibc
 +
| Add more tests to list of expected failures
 +
| Some tests failed for us and we don't have the resources to debug them
 +
| Local hack, hopefully can be dropped later.
 +
|
 +
|-
 +
| Remove ldconfig aux cache as well as main cache when upgrding from older versions
 +
| Users were having problems with videocore libraries not being found
 +
| [http://anonscm.debian.org/viewvc/pkg-glibc/glibc-package/trunk/debian/debhelper.in/?view=log commited by adconrad] to debian packaging repository, should be included in next upload.
 +
|
 +
|-
 +
| fpc
 +
| Change compiler defaults
 +
| We need the right compiler defaults for Raspbian.
 +
| Permanent Raspbian change not suitable for pushing upstream.
 +
|
 +
|-
 +
| frozen-bubble
 +
| Add build-depends on gcc-4.7
 +
| Package was trying to build with 4.7 (likely because we built Perl with it)
 +
| Now dealt with on the Perl side, and it will probablly be dropped when the next version comes through.
 +
|
 +
|-
 +
| gambas3
 +
| build with --disable-jit
 +
| [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=34&t=6182&sid=4d716a149329bd95a25970e05009c887&start=25 gambas3 with jit wasn't working]
 +
| Most likely permanent Raspbian change (unless upstream gives us a working JIT)
 +
| Unfortunately it seems that even with the JIT disabled the package apparently still didn't work.
 +
|-
 +
| gcc-4.4
 +
| Change compiler defaults
 +
| Need to build binaries suitable for Raspberry Pi
 +
| Permanent Raspbian change, not suitable for pushing upstream
 
|
 
|
 
|-
 
|-
 
| rowspan =3 | gcc-4.5
 
| rowspan =3 | gcc-4.5
| change compiler defaults
+
| Change compiler defaults
| need to build binaries suitable for rpi
+
| Need to build binaries suitable for Raspberry Pi
| permanent raspbian change, not suitable for pushing upstream
+
| Permanent Raspbian change, not suitable for pushing upstream
 
|
 
|
 
|-
 
|-
| treat wheezy the same as sid
+
| Treat Debian&nbsp;7 (Wheezy) the same as sid
| compiler built in wheezy was passing --as-needed to the linker which we don't want
+
| Compiler built in Wheezy was passing --as-needed to the linker which we don't want
| could potentially be pushed upstream to debian but given they intend to get rid of the package in the not too distant future i'm not sure there is much point
+
| Debian has dropped 4.5 already, we plan to drop it after Raspbian Wheezy
 
|
 
|
 
|-
 
|-
| disable testsuite
+
| Disable testsuite
 
| gcc testsuite takes ages and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version
 
| gcc testsuite takes ages and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version
| local hack, may be dropped later (but probablly won't)
+
| Local hack, may be dropped later (but probablly won't)
 
|
 
|
 
|-
 
|-
| subversion
+
| rowspan | gcc-4.6
| newer version from sid
+
| Change compiler defaults
| plugwash thought package was about to migrate to wheezy but it didn't actually migrate
+
| Need to build binaries suitable for Raspberry Pi
| not much we can do about this :(
+
| Permanent Raspbian change, not suitable for pushing upstream
 
|
 
|
 
|-
 
|-
| git
+
| rowspan =2 | gcc-4.7
| testsuite disabled
+
| Change compiler defaults
| testsuite failed and package was needed
+
| Need to build binaries suitable for Raspberry Pi
| seems to be a subversion related issue (debian bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=678137 678137]), fixed in debian sid but we will have to carry our own patch for wheezy.
+
| Permanent Raspbian change, not suitable for pushing upstream
 
|
 
|
 
|-
 
|-
| libatomic-ops
+
| Disable testsuite
| fixed support for armv6
+
| gcc testsuite takes ages and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version
| package failed to build with assembler errors
+
| Local hack, may be dropped later (but probablly won't)
| undecided on whether to push upstream or keep as a local change
+
 
|
 
|
 
|-
 
|-
 
| rowspan =2 | gcj-4.6
 
| rowspan =2 | gcj-4.6
| change compiler defaults
+
| Change compiler defaults
| need to build binaries suitable for rpi
+
| Need to build binaries suitable for Raspberry Pi
| permanent raspbian change, not suitable for pushing upstream
+
| Permanent Raspbian change, not suitable for pushing upstream
 
|
 
|
 
|-
 
|-
 
| disable testsuite
 
| disable testsuite
 +
| gcc testsuite takes ages, and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version
 +
| Local hack, may be dropped later (but probablly won't)
 +
|
 +
|-
 +
| rowspan =2 | gcj-4.6
 +
| Change compiler defaults
 +
| Need to build binaries suitable for Raspberry Pi
 +
| Permanent Raspbian change, not suitable for pushing upstream
 +
|
 +
|-
 +
| Disable testsuite
 
| gcc testsuite takes ages and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version
 
| gcc testsuite takes ages and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version
| local hack, may be dropped later (but probablly won't)
+
| Local hack, may be dropped later (but probablly won't).
 
|
 
|
 
|-
 
|-
| rowspan=2 | openjdk-6
+
| gdc-4.4
| Alter arm_port/hotspot/src/cpu/zero/vm/cppInterpreter_arm.S for armv6
+
| Change compiler defaults
| arm version directives in the aforementioned file were making libjvm.so in openjdk-6-jre-headless come out armv7 dirty
+
| Need to build binaries suitable for Raspberry Pi
| Probablly not suitable for pushing upstream in present form, may be able to be made suitable with extra conditionalising
+
| Permanent Raspbian change, not suitable for pushing upstream
 
|
 
|
 
|-
 
|-
| Update jamvm
+
| gdcm
| libjvm-so in icedtex6-jre-jamvm with old jamvm was coming out with armv7 code in it
+
| Reenable mono on armhf
| Likely to be kept as a local change in raspbian for wheezy. Openjdk-6 is likely to be dropped completely for jessie.
+
| Unlike Debian, we plan to bring in mono 3.x for Raspbian Wheezy
 +
| Hopefully Debian will bring back armhf mono after Wheezy
 
|
 
|
 
|-
 
|-
| qt4-x11
+
| rowspan=2 |ghc
| Disable neon
+
| Change compiler defaults for armv6
| armv6 doesn't have neon (and not all armv7 systems do either)
+
| We need armv6 code
| Debian armhf isn't supposed to require NEON either. Working out whether this should be pushed upstream would require working out if there is any runtime checking for neon in QT which I (plugwash) don't have time for ATM.
+
| Permanent Raspbian change
|Building documentation on raspbian seems to hang, when updating package a source+all upload should be built on amd64 or similar. The buildds can then fill in the remaining binaries.
+
|
 
|-
 
|-
| x264
+
| Force CPU and FPU settings in LLVM
| Disable build of neon vairant
+
| llvm was crashing
| neon variant sets of our v7 contamination checker which could possiblly obscure real problems.
+
| Horrible hack, but unless we get a ghc/llvm expert on our team it will have to remain :(
| Not suitable for pushing upstream. May be dropped if our contamination checker gets smarter.
+
 
|
 
|
 
|-
 
|-
| libvpx
+
| Git
| Disable build of neon vairant
+
| Testsuite disabled
| neon variant sets of our v7 contamination checker which could possiblly obscure real problems.
+
| Testsuite failed and package was needed
| Not suitable for pushing upstream. May be dropped if our contamination checker gets smarter.
+
| It seems to be a Subversion related issue (Debian bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=678137 678137]), fixed in Debian sid, but we will have to carry our own patch for Wheezy.
 
|
 
|
 
|-
 
|-
| guile-2.0
+
| rowspan | gnat-4.6
| testsuite disabled
+
| Change compiler defaults
| testsuite failed on plugwash's build system and package was needed
+
| Need to build binaries suitable for Raspberry Pi
| testsuite fails for debian as well, hopefully they will fix it at some point.
+
| Permanent Raspbian change, not suitable for pushing upstream
 
|
 
|
 
|-
 
|-
| pyopenssl
+
| guile-2.0
| seperate build-arch and build-indep
+
| Testsuite disabled
| documentation build was silently failing (causing a file not found error later) on raspbian
+
| Testsuite failed on plugwash's build system and package was needed
| Bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=675414 675414]submitted to debian for build-arch/build-indep split and has been fixed in experimental. No idea on root cause of documentation build issue.
+
| Testsuite fails for Debian as well. Hopefully they will fix it at some point.
 
|
 
|
 
|-
 
|-
| rowspan=2 | perl
+
| hercules
| change build-depends and debian/config.debian to build with gcc-4.7
+
| Change build-depends and debian/rules to build with gcc-4.7
 
| gcc 4.6 failed to build package with ICE
 
| gcc 4.6 failed to build package with ICE
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| Local change likely to be kept until Debian makes 4.7 the default on armhf
 
|
 
|
 
|-
 
|-
| apply hack to change default compiler for perl modules back to plain cc
+
| klibc
| Just because we built perl with 4.7 doesn't mean we want the same to apply to perl modules (it had proved a massive PITA because there was nothing to pull it in)
+
| Change build settings
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| Existing compiler settings were not suitable for Raspbian
 +
| Local change not suitable for pushing upstream
 
|
 
|
 
|-
 
|-
| libmediainfo
+
| libasync-interrupt-perl
| change build-depends and debian/config.debian to build with gcc-4.7
+
| Add build-depends on gcc-4.7
| gcc 4.6 failed to build package with ICE
+
| Package was trying to build with 4.7 (likely because we built Perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| Now dealt with on the Perl side. It will probablly be dropped with next update to package.
 
|
 
|
 
|-
 
|-
| libpd-stats-perl
+
| libatomic-ops
| add build-depends on gcc-4.7
+
| Fixed support for armv6
| package was trying to build with 4.7 (likely because we built perl with it)
+
| Package failed to build with assembler errors
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| Undecided on whether to push upstream or keep as a local change
 
|
 
|
 
|-
 
|-
| libdevice-cdio-perl
+
| libav
| add build-depends on gcc-4.7
+
| Disable build of neon flavour
| package was trying to build with 4.7 (likely because we built perl with it)
+
| We have no use for neon, and it sets off our contamination checker.
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| Permanent Raspbian change
 
|
 
|
 
|-
 
|-
| rhash
+
| libb-hooks-parser-perl
| add build-depends on gcc-4.7
+
| Add build-depends on gcc-4.7
| package was trying to build with 4.7 (likely because we built perl with it)
+
| Package was trying to build with 4.7 (likely because we built Perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| Now dealt with on the Perl side. It will probablly be dropped with the next update to the package.
 
|
 
|
 
|-
 
|-
| frozen-bubble
+
| libavg
| add build-depends on gcc-4.7
+
| Set architecture list to any and add a fallback option for some debug related inline assembler
| package was trying to build with 4.7 (likely because we built perl with it)
+
| Package was requested by user
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| Bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=683105 683105] filed in Debian
 
|
 
|
 
|-
 
|-
| libasync-interrupt-perl
+
| libccrtp1
| add build-depends on gcc-4.7
+
| New source package based on old version of libccrtp source package with renamed dev and doc packages
| package was trying to build with 4.7 (likely because we built perl with it)
+
| twinkle needed an older version of libccrtp
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| Local change for Raspbian Wheezy. For Debian 8 (Jessie) I plan to clean up packages that are no longer in Debian and tell users to install them from Wheezy.
 
|
 
|
 
|-
 
|-
| rowspan =2 | gcc-4.7
+
| libcdr
| change compiler defaults
+
| Bring in new package from experimental (not present in Debian Wheezy)
| need to build binaries suitable for rpi
+
| Experimental version of LibreOffice needed libcdr
| permanent raspbian change, not suitable for pushing upstream
+
| Hopefully the package will enter Debian testing post-Wheezy
 
|
 
|
 
|-
 
|-
| disable testsuite
+
| libcmis-experimental
| gcc testsuite takes ages and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version
+
| Raspbian specific source package based on experimental version of libcmis with renamed source package and dev package and removed client package
| local hack, may be dropped later (but probablly won't)
+
| Experimental version of LibreOffice needed newer versions of libcmis than was present in Wheezy.
 +
| Local hack, hopefully can be dropped post-Wheezy.
 
|
 
|
 
|-
 
|-
| tcsh
+
| libcoro-perl
| testsuite disabled
+
| Add build-depends on gcc-4.7
| testsuite failed and we needed to get update built to keep source and binary in sync
+
| Package was trying to build with 4.7 (likely because we built Perl with it).
| local hack, hopefully we can drop later.
+
| Now dealt with on the Perl side. It will probablly be dropped with the next update to the package.
 +
|
 +
|-
 +
| libdevice-cdio-perl
 +
| add build-depends on gcc-4.7
 +
| package was trying to build with 4.7 (likely because we built perl with it)
 +
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
Line 205: Line 307:
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libb-hooks-parser-perl
+
| libgeo-ip-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| rowspan=2 | pspp
+
| libgeotiff-dfsg
 +
| add libgeotiff-alt-dev binary package without static library or dependency on libtiff5-dev
 +
| xastir was requested by user and it's build-depends could not be satisfied due to conflict between libtiff4-dev and libtiff5-dev
 +
| patches sent to existing bug report [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=666589 666589] in debian
 +
|
 +
|-
 +
| libgpod
 +
| enable cil packages for armhf
 +
| unlike debian armhf we plan to ship mono in raspbian.
 +
| change will be raspbian specific for wheezy and should be pushed to debian after wheezy release.
 +
|
 +
|-
 +
| libheimdal-kadm5-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
| package was trying to build perl related code with 4.7 (likely because we built perl with it)
+
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| disable testsuite
+
| libipc-sharelite-perl
| testsuite failed and we don't have the resources to troubleshoot it
+
| add build-depends on gcc-4.7
| local hack which hopefully can be dropped later
+
| package was trying to build with 4.7 (likely because we built perl with it)
 +
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libvariable-magic-perl
+
| libmath-random-mt-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
Line 234: Line 349:
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
 +
| now dealt with on the perl side, will probablly be dropped with next update to package
 +
|
 +
|-
 +
| libmediainfo
 +
| change build-depends and debian/config.debian to build with gcc-4.7
 +
| gcc 4.6 failed to build package with ICE
 
| local change likely to be kept until debian makes 4.7 the default on armhf
 
| local change likely to be kept until debian makes 4.7 the default on armhf
 
|
 
|
 
|-
 
|-
| nkf
+
| libmoose-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libxml-xerces-perl
+
| libpadwalker-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libtemplate-perl
+
| libpdl-stats-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libsys-cpu-perl
+
| rowspan=3 | libreoffice
 +
| use version from experimental
 +
| testing/unstable version has a fragile build system that was causing us problems
 +
| bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=685723 685723] filed in debian (and marked as fixed in experimental)
 +
|
 +
|-
 +
| change build-dependencies from libclucene-dev and libcmis-dev to (raspbian specific) libclucene-dev-experimental and libcmis-dev-experimental
 +
| experimental version of libreoffice needed newer versions of libclucene and libcmis than were present in wheezy
 +
| local hack, hopefully can be dropped post-wheezy
 +
|
 +
|-
 +
| disable testsuite
 +
| testsuite seemed to be failing on debian armhf in experimental and there isn't much we can do about testsuite failures anyway
 +
| local hack hopefully can be dropped later.
 +
|
 +
|-
 +
| libsocket-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
Line 264: Line 401:
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libpadwalker-perl
+
| libsys-cpu-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libmoose-perl
+
| libtemplate-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libipc-sharelite-perl
+
| libv8
 +
| Modified to produce code compatible with armv6 on Raspberry Pi. Changes modeled on: https://codereview.qt-project.org/#change,27256
 +
| Jit was producing armv7 code
 +
| Hopefully upstream will pick this up eventually (if they haven't already)
 +
|
 +
|-
 +
| libvariable-magic-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libcoro-perl
+
| libvpx
 +
| Disable build of neon vairant
 +
| neon variant sets of our v7 contamination checker which could possiblly obscure real problems.
 +
| Not suitable for pushing upstream. May be dropped if our contamination checker gets smarter.
 +
|
 +
|-
 +
| libxml-libxml-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libsocket-perl
+
| libxml-xerces-perl
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build with 4.7 (likely because we built perl with it)
 
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| fpc
+
| libzrtpcpp1
| change compiler defaults
+
| new source package based on old version of libzrtpcpp1 source package with renamed dev package
| We need the right compiler defaults for raspbian
+
| current version of libzrtpcpp is not compatible with the version of libccrtp needed for twinkle.
| Permanent raspbian change not suitable for pushing upstream
+
| local change for raspbian wheezy. For jessie I plan to clean up packages that are no longer in debian and tell users to install them from wheezy.
 +
|
 +
|-
 +
| lightspark
 +
| build with gcc 4.7
 +
| gcc-4.6 failed to build package with ICE
 +
| local change likely to be kept until debian makes gcc-4.7 the default on armhf
 
|
 
|
 
|-
 
|-
| hercules
+
| linux
| change build-depends and debian/rules to build with gcc-4.7
+
| many changes to make source package build Pi kernel instead of omap, mx5 and vexpress ones.
| gcc 4.6 failed to build package with ICE
+
| we want a kernel for a Pi not some random armhf box
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| permanent raspbian change
 
|
 
|
 
|-
 
|-
| libavg
+
| rowspan=2 | lsb
| set architecture list to any and add a fallback option for some debug related inline assembler
+
| change apt scanning to look for Raspbian rather than Debian
| package was requested by user
+
| lsb_release was not giving codename correctly and this was causing pain for users
| bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=683105 683105] filed in debian
+
| Permanent raspbian change.
 
|
 
|
 
|-
 
|-
| gdal
+
| Disable testsuite
 +
| Testsuite was failing and seems to be broken
 +
| bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=699589 699589] filed in debian
 +
|
 +
|-
 +
| lvm2
 +
| apply patch to make lvm2 work on arm on more recent kernels
 +
| raspberry pi foundation is now using a 3.6 kernel
 +
| patch sent to bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=698153 698153] in debian.
 +
|
 +
|-
 +
| nkf
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
| package was trying to build perl related code with 4.7 (likely because we built perl with it)
+
| package was trying to build with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| now dealt with on the perl side, will probablly be dropped with next update to package
| when building manually make sure only the correct ruby version is installed or build will fail
+
|
 
|-
 
|-
| libgeotiff-dfsg
+
| obexftp
| add libgeotiff-alt-dev binary package without static library or dependency on libtiff5-dev
+
| add build-depends on gcc-4.7
| rowspan=2 | xastir was requested by user and it's build-depends could not be satisfied due to conflict between libtiff4-dev and libtiff5-dev
+
| package was trying to build perl related stuff with gcc-4.7 (likely because we built perl with it)
| rowspan=2 | patches sent to existing bug report [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=666589 666589] in debian
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| xastir
+
| openjdk-6
| change build-dependencies from libgeotiff-dev to libgeotiff-alt-dev
+
| Alter arm_port/hotspot/src/cpu/zero/vm/cppInterpreter_arm.S for armv6
 +
| arm version directives in the aforementioned file were making libjvm.so in openjdk-6-jre-headless come out armv7 dirty
 +
| Probablly not suitable for pushing upstream in present form, may be able to be made suitable with extra conditionalising
 
|
 
|
 
|-
 
|-
Line 342: Line 510:
 
|
 
|
 
|-
 
|-
| libxml-libxml-perl
+
| openssl
| add build-depends on gcc-4.7
+
| enable assembler optimisations
| package was trying to build with 4.7 (likely because we built perl with it)
+
| we consider ssl performance important
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| hopefully debian will do this too at some point (see bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=676533 676533])
 
|
 
|
 
|-
 
|-
| rowspan=3 | clisp
+
| p7zip
| add armhf to architecture lists
+
| build with gcc/g++ 4.7
| armhf was not in architecture lists and package was requested by user
+
| g++ 4.6 failed to build package with internal compiler error.
| rowspan=2 | bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=684631 684631] filed in debian.
+
| local change likely to be kept until debian makes 4.7 the default on armhf.
 
|
 
|
 
|-
 
|-
| apply patch from sourceforge to fix operation on modern arm
+
| rowspan=2 | perl
| package failed to build with illegal instruction error while running newly built clisp binary
+
| change build-depends and debian/config.debian to build with gcc-4.7
 +
| gcc 4.6 failed to build package with ICE
 +
| local change likely to be kept until debian makes 4.7 the default on armhf
 
|
 
|
 
|-
 
|-
| build with gcc-4.7
+
| apply hack to change default compiler for perl modules back to plain cc
| build failed with ICE
+
| Just because we built perl with 4.7 doesn't mean we want the same to apply to perl modules (it had proved a massive PITA because there was nothing to pull it in)
 
| local change likely to be kept until debian makes 4.7 the default on armhf
 
| local change likely to be kept until debian makes 4.7 the default on armhf
 
|
 
|
 
|-
 
|-
| libccrtp1
+
| rowspan=2 | pspp
| new source package based on old version of libccrtp source package with renamed dev and doc packages
+
| add build-depends on gcc-4.7
| twinkle needed an older version of libccrtp
+
| package was trying to build perl related code with 4.7 (likely because we built perl with it)
| local change for raspbian wheezy. For jessie I plan to clean up packages that are no longer in debian and tell users to install them from wheezy.
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| libzrtpcpp1
+
| disable testsuite
| new source package based on old version of libzrtpcpp1 source package with renamed dev package
+
| testsuite failed and we don't have the resources to troubleshoot it
| current version of libzrtpcpp is not compatible with the version of libccrtp needed for twinkle.
+
| local hack which hopefully can be dropped later
| local change for raspbian wheezy. For jessie I plan to clean up packages that are no longer in debian and tell users to install them from wheezy.
+
|
|  
+
 
|-
 
|-
| twinkle
+
| pyopenssl
| retintroduce package and change build-depends to libccrtp1 and libzrtcpp1
+
| seperate build-arch and build-indep
| User requested package and current versions of libccrtp and libzrtpcpp are not compatible with twinkle.
+
| documentation build was silently failing (causing a file not found error later) on raspbian
| local change for raspbian wheezy. For jessie I plan to clean up packages that are no longer in debian and tell users to install them from wheezy.
+
| Bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=675414 675414]submitted to debian for build-arch/build-indep split and has been fixed in experimental. No idea on root cause of documentation build issue.
|
+
|
 
|-
 
|-
| rrdtool
+
| qpid-cpp
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
| package was trying to build perl related stuff with gcc-4.7 (likely because we built perl with it)
+
| package was trying to build perl related code with 4.7 (likely because we built perl with it)
| local change likely to be kept until debian makes gcc-4.7 the default on armhf.
+
| now dealt with on the perl side, will probablly be dropped with next update to package
 
|
 
|
 
|-
 
|-
| obexftp
+
| qt4-x11
 +
| Disable neon
 +
| armv6 doesn't have neon (and not all armv7 systems do either)
 +
| Debian armhf isn't supposed to require NEON either. Working out whether this should be pushed upstream would require working out if there is any runtime checking for neon in QT which I (plugwash) don't have time for ATM.
 +
| Building documentation on raspbian seems to hang, when updating package a source+all upload should be built on amd64 or similar. The buildds can then fill in the remaining binaries.
 +
|-
 +
| rrdtool
 
| add build-depends on gcc-4.7
 
| add build-depends on gcc-4.7
 
| package was trying to build perl related stuff with gcc-4.7 (likely because we built perl with it)
 
| package was trying to build perl related stuff with gcc-4.7 (likely because we built perl with it)
Line 393: Line 568:
 
|
 
|
 
|-
 
|-
| rowspan=3 | libreoffice
+
| squeak-vm
| use version from experimental
+
| revert change to use system libraries
| testing/unstable version has a fragile build system that was causing us problems
+
| jpeg loading was broken
| bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=685723 685723] filed in debian (and marked as fixed in experimental)
+
| bug should probablly be filed in debian but afaict noone has got arround to it yet.
 
|
 
|
 
|-
 
|-
| change build-dependencies from libclucene-dev and libcmis-dev to (raspbian specific) libclucene-dev-experimental and libcmis-dev-experimental
+
| subversion
| experimental version of libreoffice needed newer versions of libclucene and libcmis than were present in wheezy
+
| newer version from sid
| local hack, hopefully can be dropped post-wheezy
+
| plugwash thought package was about to migrate to wheezy but it didn't actually migrate
 +
| not much we can do about this :(
 
|
 
|
 
|-
 
|-
| disable testsuite
+
| tcsh
| testsuite seemed to be failing on debian armhf in experimental and there isn't much we can do about testsuite failures anyway
+
| testsuite disabled
| local hack hopefully can be dropped later.
+
| testsuite failed and we needed to get update built to keep source and binary in sync
 +
| local hack, hopefully we can drop later.
 
|
 
|
 
|-
 
|-
| clucene-core-experimental
+
| ttf-opensymbol
| raspbian specific source package based on experimental version of clucene-core with renamed source package and dev package
+
| new source package to build dummy package as libreoffice version used in raspbian no longer builds it
| experimental version of libreoffice needed newer versions of libclucene than was present in wheezy
+
| libreoffice in raspbian was updated to experimental version due to build issues (see above)
| local hack, hopefully can be dropped post-wheezy
+
| will be permanent in raspbian wheezy, hopefully can be dropped for jessie
 
|
 
|
 
|-
 
|-
| libcmis-experimental
+
| twinkle
| raspbian specific source package based on experimental version of libcmis with renamed source package and dev package and removed client package
+
| retintroduce package and change build-depends to libccrtp1 and libzrtcpp1
| experimental version of libreoffice needed newer versions of libcmis than was present in wheezy
+
| User requested package and current versions of libccrtp and libzrtpcpp are not compatible with twinkle.
| local hack, hopefully can be dropped post-wheezy
+
| local change for raspbian wheezy. For jessie I plan to clean up packages that are no longer in debian and tell users to install them from wheezy.
|
+
|  
 
|-
 
|-
| libcdr
+
| valgrind
| bring in new package from experimental (not present in debian wheezy)
+
| various fixes to make package build/work for armv6
| experimental version of libreoffice needed libcdr
+
| valgrind was broken
| hopefully package will enter debian testing post-wheezy
+
| hopefully upstream will deal with this sooner or later but we may have to carry it locally for a while
 
|
 
|
 
|-
 
|-
| libheimdal-kadm5-perl
+
| virtuoso-opensource
| add build-depends on gcc-4.7
+
| revert removal of mono stuff from armhf
| package was trying to build with 4.7 (likely because we built perl with it)
+
| unlike debian armhf we plan to ship mono in raspbian
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| will be raspbian specific change for wheezy, hopefully for jessie debian will get a mono version that works on armhf too.
 
|
 
|
 
|-
 
|-
| libgeo-ip-perl
+
| webkit
| add build-depends on gcc-4.7
+
| disable JIT
| package was trying to build with 4.7 (likely because we built perl with it)
+
| JIT doesn't seem to work on sub-armv7
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| should probablly be dealt with in debian too but someone else can fight that battle
 
|
 
|
 
|-
 
|-
| rowspan=2 | ekg2
+
| x264
| add build-depends on gcc-4.7
+
| Disable build of neon variant
| package was trying to build perl related code with 4.7 (likely because we built perl with it)
+
| neon variant sets of our v7 contamination checker which could possiblly obscure real problems.
| local change likely to be kept until debian makes 4.7 the default on armhf
+
| Not suitable for pushing upstream. May be dropped if our contamination checker gets smarter.
 
|
 
|
 
|-
 
|-
| "commit" changes to config.sub and config.guess
+
| xastir
| source package could not be built after running clean target due to config.sub and config.guess changes
+
| change build-dependencies from libgeotiff-dev to libgeotiff-alt-dev
| bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=690112 690112] filed in debian.
+
| xastir was requested by user and it's build-depends could not be satisfied due to conflict between libtiff4-dev and libtiff5-dev
 +
| patches sent to existing bug report [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=666589 666589] in debian
 
|
 
|
 
|-
 
|-
| abiword
+
| rowspan=2 | xdotool
| remove build-depends on valgrind
+
| force build with ruby 1.8
| we don't currently have valgrind in debian and abiword doesn't really need it (it's only used to run build-time tests)
+
| build failed with ruby 1.9.1 and last successful build in debian had been with ruby1.8
| local change to be kept until/unless someone ports valgrind successfully.
+
| appears debian has done the same in TPU
 
|
 
|
 
|-
 
|-
| klibc
+
| disable testsuite
| change build settings
+
| testsuite was failling and we don't have the resources to debug it
| existing compiler settings were not suitable for raspbian
+
| appears debian has also disabled some tests in TPU
| local change not suitable for pushing upstream
+
|
+
|-
+
| webkit
+
| disable JIT
+
| JIT doesn't seem to work on sub-armv7
+
| should probablly be dealt with in debian too but someone else can fight that battle
+
| 1.8.1-3.3 has no changes over 1.8.1-2 that I consider important for raspbian (the only one that is even vaugely relavent is a change of compression format) so there is currently no-point in doing a forward port.
+
|-
+
| libgpod
+
| enable cil packages for armhf
+
| unlike debian armhf we plan to ship mono in raspbian.
+
| change will be raspbian specific for wheezy and should be pushed to debian after wheezy release.
+
|
+
|-
+
| eglibc
+
| add more tests to list of expected failures
+
| some tests failed for us and we don't have the resources to debug them
+
| Local hack, hopefully can be dropped later.
+
 
|
 
|
 
|}
 
|}

Latest revision as of 23:51, 29 November 2014


Raspbian is a project to create a hard float port of Debian for the Raspberry Pi and similar devices which use ARMv6 processors with VFPv2. The official Debian armhf packages are built with ARMv7, VFPv3_D16 and Thumb2. So they are not suitable for the Raspberry Pi and similar devices. To get round this we have to change the compiler defaults (easy) and recompile everything (harder than it sounds).

Infrastructure has been set-up for building packages. We aim to stay as close to Debian 7 (Wheezy) as possible, but we will pull in packages from sid and/or make our own modifications when we deem it necessary.

A chroot can be bootstrapped from a Debian 6.0 (Squeeze) armel installation using the following commands (replace /chroots/wheezy-armhf-rpi with where you want your chroot).

debootstrap --arch=armhf wheezy /chroots/wheezy-armhf-rpi http://archive.raspbian.org/raspbian
cd /chroots/wheezy-armhf-rpi
wget http://archive.raspbian.org/raspbian.public.key
chroot /chroots/wheezy-armhf-rpi
mount -t proc proc /proc
apt-key add raspbian.public.key
apt-get update

If you just want to install the minimum number of packages add a --variant=minbase to the bootstrap command

Since this is running in a chroot you probably don't want it attempting to start and stop services when you update packages. To avoid this create a file /usr/sbin/policy-rc.d with the following commands.

cat << EOD >/usr/sbin/policy-rc.d
#!/bin/sh
echo "rc.d operations disabled for chroot"
exit 101
EOD
chmod 0755 /usr/sbin/policy-rc.d

Create your own Raspbian Image

Modified packages

Note: this list is incomplete

Source package Changes Reason Status Notes
abiword remove build-depends on valgrind We didn't have Valgrind in Raspbian at the time and abiword doesn't really need it (it's only used to run build-time tests) We now have a working Valgrind, so this should be dropped the next time the package is updated.
apparmor add build-depends on gcc-4.7 The package was trying to build Perl-related stuff with gcc-4.7 due to changes we made in the Perl packaging. It is now dealt with on the Perl side. The change to be dropped next time a new version comes in.
apt Change dependency from debian-archive-keyring to raspbian-archive-keyring We don't want Raspbian users to have the Debian archive keyring and we do want them to have the Debian one. Permanent Raspbian change
ceph disable use of libatomic-ops libatomic-ops and ceph don't seem to work together on plain armv6 Most likely permanent Raspbian change
chromium-browser Set v8 settings for armv6 in debian/rules (based on work by Florian Will) raspbian is built for armv6 most likely permanent Raspbian change build memory and address space use is a massive PITA
Fix build settings for embedded ffmpeg to produce armv6 code
Build with bfd instead of gold Avoid segfault on startup Discussed in Debian bug 696909, not applied in Debian yet due to other problems.
clisp Add armhf to architecture lists armhf was not in architecture lists and package was requested by user bug 684631 filed in debian.
Apply patch from SourceForge to fix operation on modern ARM Package failed to build with illegal instruction error while running newly built clisp binary.
Build with gcc-4.7 Build failed with ICE Local change likely to be kept until Debian makes 4.7 the default on armhf
clucene-core-experimental Raspbian specific source package based on experimental version of clucene-core with renamed source package and dev package. Experimental version of LibreOffice needed newer versions of libclucene than was present in Debian 7 (Wheezy). Local hack that hopefully can be dropped post-Wheezy
eglibc Add more tests to list of expected failures Some tests failed for us and we don't have the resources to debug them Local hack, hopefully can be dropped later.
Remove ldconfig aux cache as well as main cache when upgrding from older versions Users were having problems with videocore libraries not being found commited by adconrad to debian packaging repository, should be included in next upload.
fpc Change compiler defaults We need the right compiler defaults for Raspbian. Permanent Raspbian change not suitable for pushing upstream.
frozen-bubble Add build-depends on gcc-4.7 Package was trying to build with 4.7 (likely because we built Perl with it) Now dealt with on the Perl side, and it will probablly be dropped when the next version comes through.
gambas3 build with --disable-jit gambas3 with jit wasn't working Most likely permanent Raspbian change (unless upstream gives us a working JIT) Unfortunately it seems that even with the JIT disabled the package apparently still didn't work.
gcc-4.4 Change compiler defaults Need to build binaries suitable for Raspberry Pi Permanent Raspbian change, not suitable for pushing upstream
gcc-4.5 Change compiler defaults Need to build binaries suitable for Raspberry Pi Permanent Raspbian change, not suitable for pushing upstream
Treat Debian 7 (Wheezy) the same as sid Compiler built in Wheezy was passing --as-needed to the linker which we don't want Debian has dropped 4.5 already, we plan to drop it after Raspbian Wheezy
Disable testsuite gcc testsuite takes ages and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version Local hack, may be dropped later (but probablly won't)
gcc-4.6 Change compiler defaults Need to build binaries suitable for Raspberry Pi Permanent Raspbian change, not suitable for pushing upstream
gcc-4.7 Change compiler defaults Need to build binaries suitable for Raspberry Pi Permanent Raspbian change, not suitable for pushing upstream
Disable testsuite gcc testsuite takes ages and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version Local hack, may be dropped later (but probablly won't)
gcj-4.6 Change compiler defaults Need to build binaries suitable for Raspberry Pi Permanent Raspbian change, not suitable for pushing upstream
disable testsuite gcc testsuite takes ages, and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version Local hack, may be dropped later (but probablly won't)
gcj-4.6 Change compiler defaults Need to build binaries suitable for Raspberry Pi Permanent Raspbian change, not suitable for pushing upstream
Disable testsuite gcc testsuite takes ages and we don't have the resources to do anything about failures anyway, especially for a non-default compiler version Local hack, may be dropped later (but probablly won't).
gdc-4.4 Change compiler defaults Need to build binaries suitable for Raspberry Pi Permanent Raspbian change, not suitable for pushing upstream
gdcm Reenable mono on armhf Unlike Debian, we plan to bring in mono 3.x for Raspbian Wheezy Hopefully Debian will bring back armhf mono after Wheezy
ghc Change compiler defaults for armv6 We need armv6 code Permanent Raspbian change
Force CPU and FPU settings in LLVM llvm was crashing Horrible hack, but unless we get a ghc/llvm expert on our team it will have to remain :(
Git Testsuite disabled Testsuite failed and package was needed It seems to be a Subversion related issue (Debian bug 678137), fixed in Debian sid, but we will have to carry our own patch for Wheezy.
gnat-4.6 Change compiler defaults Need to build binaries suitable for Raspberry Pi Permanent Raspbian change, not suitable for pushing upstream
guile-2.0 Testsuite disabled Testsuite failed on plugwash's build system and package was needed Testsuite fails for Debian as well. Hopefully they will fix it at some point.
hercules Change build-depends and debian/rules to build with gcc-4.7 gcc 4.6 failed to build package with ICE Local change likely to be kept until Debian makes 4.7 the default on armhf
klibc Change build settings Existing compiler settings were not suitable for Raspbian Local change not suitable for pushing upstream
libasync-interrupt-perl Add build-depends on gcc-4.7 Package was trying to build with 4.7 (likely because we built Perl with it) Now dealt with on the Perl side. It will probablly be dropped with next update to package.
libatomic-ops Fixed support for armv6 Package failed to build with assembler errors Undecided on whether to push upstream or keep as a local change
libav Disable build of neon flavour We have no use for neon, and it sets off our contamination checker. Permanent Raspbian change
libb-hooks-parser-perl Add build-depends on gcc-4.7 Package was trying to build with 4.7 (likely because we built Perl with it) Now dealt with on the Perl side. It will probablly be dropped with the next update to the package.
libavg Set architecture list to any and add a fallback option for some debug related inline assembler Package was requested by user Bug 683105 filed in Debian
libccrtp1 New source package based on old version of libccrtp source package with renamed dev and doc packages twinkle needed an older version of libccrtp Local change for Raspbian Wheezy. For Debian 8 (Jessie) I plan to clean up packages that are no longer in Debian and tell users to install them from Wheezy.
libcdr Bring in new package from experimental (not present in Debian Wheezy) Experimental version of LibreOffice needed libcdr Hopefully the package will enter Debian testing post-Wheezy
libcmis-experimental Raspbian specific source package based on experimental version of libcmis with renamed source package and dev package and removed client package Experimental version of LibreOffice needed newer versions of libcmis than was present in Wheezy. Local hack, hopefully can be dropped post-Wheezy.
libcoro-perl Add build-depends on gcc-4.7 Package was trying to build with 4.7 (likely because we built Perl with it). Now dealt with on the Perl side. It will probablly be dropped with the next update to the package.
libdevice-cdio-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libfilter-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libgeo-ip-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libgeotiff-dfsg add libgeotiff-alt-dev binary package without static library or dependency on libtiff5-dev xastir was requested by user and it's build-depends could not be satisfied due to conflict between libtiff4-dev and libtiff5-dev patches sent to existing bug report 666589 in debian
libgpod enable cil packages for armhf unlike debian armhf we plan to ship mono in raspbian. change will be raspbian specific for wheezy and should be pushed to debian after wheezy release.
libheimdal-kadm5-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libipc-sharelite-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libmath-random-mt-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libmath-tamuanova-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libmediainfo change build-depends and debian/config.debian to build with gcc-4.7 gcc 4.6 failed to build package with ICE local change likely to be kept until debian makes 4.7 the default on armhf
libmoose-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libpadwalker-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libpdl-stats-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libreoffice use version from experimental testing/unstable version has a fragile build system that was causing us problems bug 685723 filed in debian (and marked as fixed in experimental)
change build-dependencies from libclucene-dev and libcmis-dev to (raspbian specific) libclucene-dev-experimental and libcmis-dev-experimental experimental version of libreoffice needed newer versions of libclucene and libcmis than were present in wheezy local hack, hopefully can be dropped post-wheezy
disable testsuite testsuite seemed to be failing on debian armhf in experimental and there isn't much we can do about testsuite failures anyway local hack hopefully can be dropped later.
libsocket-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libsort-key-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libsys-cpu-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libtemplate-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libv8 Modified to produce code compatible with armv6 on Raspberry Pi. Changes modeled on: https://codereview.qt-project.org/#change,27256 Jit was producing armv7 code Hopefully upstream will pick this up eventually (if they haven't already)
libvariable-magic-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libvpx Disable build of neon vairant neon variant sets of our v7 contamination checker which could possiblly obscure real problems. Not suitable for pushing upstream. May be dropped if our contamination checker gets smarter.
libxml-libxml-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libxml-xerces-perl add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
libzrtpcpp1 new source package based on old version of libzrtpcpp1 source package with renamed dev package current version of libzrtpcpp is not compatible with the version of libccrtp needed for twinkle. local change for raspbian wheezy. For jessie I plan to clean up packages that are no longer in debian and tell users to install them from wheezy.
lightspark build with gcc 4.7 gcc-4.6 failed to build package with ICE local change likely to be kept until debian makes gcc-4.7 the default on armhf
linux many changes to make source package build Pi kernel instead of omap, mx5 and vexpress ones. we want a kernel for a Pi not some random armhf box permanent raspbian change
lsb change apt scanning to look for Raspbian rather than Debian lsb_release was not giving codename correctly and this was causing pain for users Permanent raspbian change.
Disable testsuite Testsuite was failing and seems to be broken bug 699589 filed in debian
lvm2 apply patch to make lvm2 work on arm on more recent kernels raspberry pi foundation is now using a 3.6 kernel patch sent to bug 698153 in debian.
nkf add build-depends on gcc-4.7 package was trying to build with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
obexftp add build-depends on gcc-4.7 package was trying to build perl related stuff with gcc-4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
openjdk-6 Alter arm_port/hotspot/src/cpu/zero/vm/cppInterpreter_arm.S for armv6 arm version directives in the aforementioned file were making libjvm.so in openjdk-6-jre-headless come out armv7 dirty Probablly not suitable for pushing upstream in present form, may be able to be made suitable with extra conditionalising
openjdk-7 Alter openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_arm.S for armv6 arm version directives in the aforementioned file were making libjvm.so in openjdk-6-jre-headless come out armv7 dirty Probablly not suitable for pushing upstream in present form, may be able to be made suitable with extra conditionalising
Update to newer version from experimental libjvm-so in icedtex6-jre-jamvm from the testing/unstable version was coming out with armv7 code in it Hopefully debian testing/unstable will get this new version soon.
openssl enable assembler optimisations we consider ssl performance important hopefully debian will do this too at some point (see bug 676533)
p7zip build with gcc/g++ 4.7 g++ 4.6 failed to build package with internal compiler error. local change likely to be kept until debian makes 4.7 the default on armhf.
perl change build-depends and debian/config.debian to build with gcc-4.7 gcc 4.6 failed to build package with ICE local change likely to be kept until debian makes 4.7 the default on armhf
apply hack to change default compiler for perl modules back to plain cc Just because we built perl with 4.7 doesn't mean we want the same to apply to perl modules (it had proved a massive PITA because there was nothing to pull it in) local change likely to be kept until debian makes 4.7 the default on armhf
pspp add build-depends on gcc-4.7 package was trying to build perl related code with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
disable testsuite testsuite failed and we don't have the resources to troubleshoot it local hack which hopefully can be dropped later
pyopenssl seperate build-arch and build-indep documentation build was silently failing (causing a file not found error later) on raspbian Bug 675414submitted to debian for build-arch/build-indep split and has been fixed in experimental. No idea on root cause of documentation build issue.
qpid-cpp add build-depends on gcc-4.7 package was trying to build perl related code with 4.7 (likely because we built perl with it) now dealt with on the perl side, will probablly be dropped with next update to package
qt4-x11 Disable neon armv6 doesn't have neon (and not all armv7 systems do either) Debian armhf isn't supposed to require NEON either. Working out whether this should be pushed upstream would require working out if there is any runtime checking for neon in QT which I (plugwash) don't have time for ATM. Building documentation on raspbian seems to hang, when updating package a source+all upload should be built on amd64 or similar. The buildds can then fill in the remaining binaries.
rrdtool add build-depends on gcc-4.7 package was trying to build perl related stuff with gcc-4.7 (likely because we built perl with it) local change likely to be kept until debian makes gcc-4.7 the default on armhf.
squeak-vm revert change to use system libraries jpeg loading was broken bug should probablly be filed in debian but afaict noone has got arround to it yet.
subversion newer version from sid plugwash thought package was about to migrate to wheezy but it didn't actually migrate not much we can do about this :(
tcsh testsuite disabled testsuite failed and we needed to get update built to keep source and binary in sync local hack, hopefully we can drop later.
ttf-opensymbol new source package to build dummy package as libreoffice version used in raspbian no longer builds it libreoffice in raspbian was updated to experimental version due to build issues (see above) will be permanent in raspbian wheezy, hopefully can be dropped for jessie
twinkle retintroduce package and change build-depends to libccrtp1 and libzrtcpp1 User requested package and current versions of libccrtp and libzrtpcpp are not compatible with twinkle. local change for raspbian wheezy. For jessie I plan to clean up packages that are no longer in debian and tell users to install them from wheezy.
valgrind various fixes to make package build/work for armv6 valgrind was broken hopefully upstream will deal with this sooner or later but we may have to carry it locally for a while
virtuoso-opensource revert removal of mono stuff from armhf unlike debian armhf we plan to ship mono in raspbian will be raspbian specific change for wheezy, hopefully for jessie debian will get a mono version that works on armhf too.
webkit disable JIT JIT doesn't seem to work on sub-armv7 should probablly be dealt with in debian too but someone else can fight that battle
x264 Disable build of neon variant neon variant sets of our v7 contamination checker which could possiblly obscure real problems. Not suitable for pushing upstream. May be dropped if our contamination checker gets smarter.
xastir change build-dependencies from libgeotiff-dev to libgeotiff-alt-dev xastir was requested by user and it's build-depends could not be satisfied due to conflict between libtiff4-dev and libtiff5-dev patches sent to existing bug report 666589 in debian
xdotool force build with ruby 1.8 build failed with ruby 1.9.1 and last successful build in debian had been with ruby1.8 appears debian has done the same in TPU
disable testsuite testsuite was failling and we don't have the resources to debug it appears debian has also disabled some tests in TPU