Difference between revisions of "User:Maxion"

From eLinux.org
Jump to: navigation, search
(Working USB Webcams)
(USB Webcams)
 
(12 intermediate revisions by the same user not shown)
Line 1: Line 1:
===Working USB Webcams===
+
===USB Webcams===
 
<div style="margin: -.3em -1em -1em -1em;">
 
<div style="margin: -.3em -1em -1em -1em;">
 
{| width="100%" bgcolor="#fff" border="0" cellpadding="2px" cellspacing="2px" style="margin:auto;"
 
{| width="100%" bgcolor="#fff" border="0" cellpadding="2px" cellspacing="2px" style="margin:auto;"
Line 8: Line 8:
 
| '''Hardware ID'''
 
| '''Hardware ID'''
 
| '''Verified OS'''
 
| '''Verified OS'''
| ''"Resolution''"
+
| '''Verified OS version'''
 +
| '''Verified Resolution'''
 
| '''Additional Information'''
 
| '''Additional Information'''
  
  
|- valign="top" align="left" style="background: #F5FAFF;"
+
|- valign="top" align="left" style="background: #F6D2CF;"
 
|Canyon
 
|Canyon
 
|
 
|
 
|CNR-WCAM820
 
|CNR-WCAM820
 
|
 
|
 +
| raspbian/wheezy
 
|
 
|
| 2 Mpixel
+
| 1280x1024
 
| 2 Mpixel camera with manual focus; works with fswebcam and v4l4j on Raspbian Wheezy armhf; problems with 1600x1200 resolution in some apps (timeouts - probably too slow USB); 1280x1024 and lower resolutions works OK
 
| 2 Mpixel camera with manual focus; works with fswebcam and v4l4j on Raspbian Wheezy armhf; problems with 1600x1200 resolution in some apps (timeouts - probably too slow USB); 1280x1024 and lower resolutions works OK
  
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Creative
 +
|Live!
 +
| VF0470
 +
|
 +
| ArchLinux
 +
|
 +
|
 +
| works out of the box on ArchLinux
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Creative
 +
|Live! Cam Socialize HD
 +
| VF0610
 +
|041e:4080
 +
| raspbian/wheezy
 +
| 2012-11-26
 +
| 960x544
 +
| Works at 1280x720 taking stills in fswebcam with some errors using MJPEG, unusable with YUYV. 960x544 works in both MJPEG and YUYV. Has some stabilitiy issues if powered from RasPi (Drops USB +eth0 every 8 or so hours). Helps to append nodrop=1 and timeout=5000 to uvcvideo module.
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Creative
 +
|Live! Cam Vista IM
 +
| VF0640
 +
|
 +
| raspbian/wheezy
 +
|
 +
|
 +
| works on Raspbian at 320x240 resolution, 15fps
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Creative
 +
|Webcam Notebook
 +
| PD1170
 +
|
 +
|
 +
|
 +
|
 +
| Detects, untested.
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Creative
 +
|Webcam Pro
 +
| PD1030
 +
|
 +
|
 +
|
 +
|
 +
|  ov519 driver crashes almost immediately. ("gspca: ISOC data error: [0] len=0, status=-4004")
 +
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|HP
 +
|WebcamHD-2200
 +
| HD-2200
 +
|
 +
|
 +
|
 +
|
 +
|
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|HP
 +
|Webcam HP-3100
 +
|HP-3100
 +
|
 +
|
 +
|
 +
|
 +
| UVCVideo /dev/video0 Needs chmod to 666 to operate. Will work without hub if only device in USB ports. Works with both Arch and Wheezy out of the box
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|Webcam C100
 +
| V-U0013
 +
|
 +
| raspbian/wheezy
 +
| 2012-08-16
 +
|
 +
| works fine without powered hub
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|Webcam C200
 +
|
 +
| 046d:0802
 +
|
 +
|
 +
|
 +
|
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|Webcam C270
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| With external power
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|Webcam C310
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| Does not require a powered hub to capture snapshots
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|Webcam C510
 +
|
 +
|
 +
|
 +
|
 +
|
 +
|
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|Webcam C525
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| Works fine without powered hub
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|Webcam C615
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| Works fine without powered hub
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|Webcam C910
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| With external power, is uncvideo
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|Webcam C920
 +
|
 +
|
 +
| raspbian/wheezy
 +
|
 +
|
 +
| With powered hub, detected out of box as Video0 V4L device
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|QuickCam Orbit/Sphere
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| Works with external power
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Logitech
 +
|QuickCam Pro 9000
 +
|
 +
|
 +
| raspbian/wheezy
 +
|
 +
|
 +
| Powered by RasPi
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Logitech
 +
|Webcam Pro 4000
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| It uses pwc driver which does not work. Maybe it's because of general Raspberry Pi USB bug.
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Logitech
 +
|Webcam Pro 9000
 +
|
 +
| 046d:0809
 +
| Arch Linux
 +
|
 +
|
 +
| Powered by RasPi, measured ~120 mA current capturing at ~5fps. Has issues capturing images at higher than default resolutions (using motion - Arch and Debian).
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Medion
 +
|
 +
| MD86511
 +
|
 +
| raspbian/wheezy
 +
| 2012-07-15
 +
|
 +
| Powered by RasPi
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Microsoft
 +
|LifeCam Cinemap 720p USB HD Webcam
 +
| H5D-00001
 +
|
 +
| raspbian/wheezy
 +
|
 +
|
 +
|
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Microsoft
 +
|LifeCam HD-5000
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| Picture breaks up at the bottom
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Microsoft
 +
|LifeCam HD-6000
 +
|
 +
|
 +
| raspbian/wheezy 
 +
|
 +
|
 +
| Powered by USB hub
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Microsoft
 +
|LifeCam
 +
| NX-6000
 +
|
 +
| raspbian/wheezy
 +
|
 +
|
 +
| Powered by USB hub
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Microsoft
 +
|LifeCam
 +
| VX-7000
 +
|
 +
| raspbian/wheezy
 +
|
 +
|
 +
| Powered by USB hub
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Microsoft
 +
|LifeCam
 +
| VX-3000
 +
|
 +
| raspbian/wheezy
 +
|
 +
|
 +
| There do appear to be some issues with image quality and getting partial frames and such, with fswebcam
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Microsoft
 +
|LifeCam
 +
| NX-6000
 +
|
 +
| raspbian/wheezy
 +
|
 +
|
 +
| Powered by USB hub
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Microsoft
 +
|LifeCam
 +
| VX-800
 +
|
 +
| raspbian/wheezy
 +
|
 +
| 352x288
 +
| Doesn't work at full resolution
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Microsoft
 +
|LifeCam Studio/Cinema
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| Has UVC issues detailed here [http://www.ideasonboard.org/uvc/#devices]. Horizontal lines problem [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=12304]. Stability issues [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=12247].
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Microsoft
 +
|Xbox Live Vision
 +
|
 +
| 045e:0294
 +
| Arch Linux
 +
|
 +
|
 +
| Powered by RasPi
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Sony
 +
| Playstation Eye for PS3
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| The occasional frame is corrupted/stutters when running at 640x480
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Sony
 +
| Playstation Eye for PS2
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| Occasional 'mangled frame' directly connected to Rev 2 Raspberry P
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Sony
 +
| Playstation Eye for PS2
 +
| SLEH 00030
 +
|
 +
| Arch Linux
 +
|
 +
|
 +
| (OV519 camera). Picture constantly breaks up on xawtv and wxcam under Arch Linux. Noted there were ISOC data error len=0 status=-4004 errors in dmesg. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB hub. Arch was updated on 17th July 2012
 +
 +
|- valign="top" align="left" style="background: #F5FAFF;"
 +
|Trust
 +
| 2 MP Auto Focus Webcam
 +
|
 +
|
 +
| Arch Linux
 +
|
 +
|
 +
| works out of the box
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Trust
 +
| SPACEC@M 200
 +
|
 +
|
 +
| Arch Linux
 +
|
 +
|
 +
| (OV511 camera). Picture stops after a few seconds in xawtv under Arch Linux and xawtv reports libv4l2 errors. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB Hub. Arch was updated on 17th July 2012
  
  
 
|-
 
|-
 
|}
 
|}

Latest revision as of 13:27, 7 December 2012

USB Webcams

Brand Name Model Number Hardware ID Verified OS Verified OS version Verified Resolution Additional Information


Canyon CNR-WCAM820 raspbian/wheezy 1280x1024 2 Mpixel camera with manual focus; works with fswebcam and v4l4j on Raspbian Wheezy armhf; problems with 1600x1200 resolution in some apps (timeouts - probably too slow USB); 1280x1024 and lower resolutions works OK
Creative Live! VF0470 ArchLinux works out of the box on ArchLinux
Creative Live! Cam Socialize HD VF0610 041e:4080 raspbian/wheezy 2012-11-26 960x544 Works at 1280x720 taking stills in fswebcam with some errors using MJPEG, unusable with YUYV. 960x544 works in both MJPEG and YUYV. Has some stabilitiy issues if powered from RasPi (Drops USB +eth0 every 8 or so hours). Helps to append nodrop=1 and timeout=5000 to uvcvideo module.
Creative Live! Cam Vista IM VF0640 raspbian/wheezy works on Raspbian at 320x240 resolution, 15fps
Creative Webcam Notebook PD1170 Detects, untested.
Creative Webcam Pro PD1030 ov519 driver crashes almost immediately. ("gspca: ISOC data error: [0] len=0, status=-4004")


HP WebcamHD-2200 HD-2200
HP Webcam HP-3100 HP-3100 UVCVideo /dev/video0 Needs chmod to 666 to operate. Will work without hub if only device in USB ports. Works with both Arch and Wheezy out of the box
Logitech Webcam C100 V-U0013 raspbian/wheezy 2012-08-16 works fine without powered hub
Logitech Webcam C200 046d:0802
Logitech Webcam C270 With external power
Logitech Webcam C310 Does not require a powered hub to capture snapshots
Logitech Webcam C510
Logitech Webcam C525 Works fine without powered hub
Logitech Webcam C615 Works fine without powered hub
Logitech Webcam C910 With external power, is uncvideo
Logitech Webcam C920 raspbian/wheezy With powered hub, detected out of box as Video0 V4L device
Logitech QuickCam Orbit/Sphere Works with external power
Logitech QuickCam Pro 9000 raspbian/wheezy Powered by RasPi
Logitech Webcam Pro 4000 It uses pwc driver which does not work. Maybe it's because of general Raspberry Pi USB bug.
Logitech Webcam Pro 9000 046d:0809 Arch Linux Powered by RasPi, measured ~120 mA current capturing at ~5fps. Has issues capturing images at higher than default resolutions (using motion - Arch and Debian).
Medion MD86511 raspbian/wheezy 2012-07-15 Powered by RasPi
Microsoft LifeCam Cinemap 720p USB HD Webcam H5D-00001 raspbian/wheezy
Microsoft LifeCam HD-5000 Picture breaks up at the bottom
Microsoft LifeCam HD-6000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam NX-6000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam VX-7000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam VX-3000 raspbian/wheezy There do appear to be some issues with image quality and getting partial frames and such, with fswebcam
Microsoft LifeCam NX-6000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam VX-800 raspbian/wheezy 352x288 Doesn't work at full resolution
Microsoft LifeCam Studio/Cinema Has UVC issues detailed here [1]. Horizontal lines problem [2]. Stability issues [3].
Microsoft Xbox Live Vision 045e:0294 Arch Linux Powered by RasPi
Sony Playstation Eye for PS3 The occasional frame is corrupted/stutters when running at 640x480
Sony Playstation Eye for PS2 Occasional 'mangled frame' directly connected to Rev 2 Raspberry P
Sony Playstation Eye for PS2 SLEH 00030 Arch Linux (OV519 camera). Picture constantly breaks up on xawtv and wxcam under Arch Linux. Noted there were ISOC data error len=0 status=-4004 errors in dmesg. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB hub. Arch was updated on 17th July 2012
Trust 2 MP Auto Focus Webcam Arch Linux works out of the box
Trust SPACEC@M 200 Arch Linux (OV511 camera). Picture stops after a few seconds in xawtv under Arch Linux and xawtv reports libv4l2 errors. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB Hub. Arch was updated on 17th July 2012