Difference between revisions of "User:Maxion"

From eLinux.org
Jump to: navigation, search
(Working USB Webcams)
(USB Webcams)
 
(5 intermediate revisions by the same user not shown)
Line 1: Line 1:
===Working USB Webcams===
+
===USB Webcams===
 
<div style="margin: -.3em -1em -1em -1em;">
 
<div style="margin: -.3em -1em -1em -1em;">
 
{| width="100%" bgcolor="#fff" border="0" cellpadding="2px" cellspacing="2px" style="margin:auto;"
 
{| width="100%" bgcolor="#fff" border="0" cellpadding="2px" cellspacing="2px" style="margin:auto;"
Line 8: Line 8:
 
| '''Hardware ID'''
 
| '''Hardware ID'''
 
| '''Verified OS'''
 
| '''Verified OS'''
| '''Resolution'''
+
| '''Verified OS version'''
 +
| '''Verified Resolution'''
 
| '''Additional Information'''
 
| '''Additional Information'''
  
  
|- valign="top" align="left" style="background: #F5FAFF;"
+
|- valign="top" align="left" style="background: #F6D2CF;"
 
|Canyon
 
|Canyon
 
|
 
|
 
|CNR-WCAM820
 
|CNR-WCAM820
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
| 2 Mpixel
+
|
 +
| 1280x1024
 
| 2 Mpixel camera with manual focus; works with fswebcam and v4l4j on Raspbian Wheezy armhf; problems with 1600x1200 resolution in some apps (timeouts - probably too slow USB); 1280x1024 and lower resolutions works OK
 
| 2 Mpixel camera with manual focus; works with fswebcam and v4l4j on Raspbian Wheezy armhf; problems with 1600x1200 resolution in some apps (timeouts - probably too slow USB); 1280x1024 and lower resolutions works OK
  
Line 28: Line 30:
 
| ArchLinux
 
| ArchLinux
 
|  
 
|  
 +
|
 
| works out of the box on ArchLinux
 
| works out of the box on ArchLinux
  
|- valign="top" align="left" style="background: #F5FAFF;"
+
|- valign="top" align="left" style="background: #F6D2CF;"
 
|Creative
 
|Creative
 
|Live! Cam Socialize HD
 
|Live! Cam Socialize HD
| 041e:4080
+
| VF0610
|
+
|041e:4080
| Raspbian Wheezy 2012-11-26
+
| raspbian/wheezy
|  
+
| 2012-11-26
 +
| 960x544
 
| Works at 1280x720 taking stills in fswebcam with some errors using MJPEG, unusable with YUYV. 960x544 works in both MJPEG and YUYV. Has some stabilitiy issues if powered from RasPi (Drops USB +eth0 every 8 or so hours). Helps to append nodrop=1 and timeout=5000 to uvcvideo module.
 
| Works at 1280x720 taking stills in fswebcam with some errors using MJPEG, unusable with YUYV. 960x544 works in both MJPEG and YUYV. Has some stabilitiy issues if powered from RasPi (Drops USB +eth0 every 8 or so hours). Helps to append nodrop=1 and timeout=5000 to uvcvideo module.
  
|- valign="top" align="left" style="background: #F5FAFF;"
+
|- valign="top" align="left" style="background: #F6D2CF;"
 
|Creative
 
|Creative
 
|Live! Cam Vista IM
 
|Live! Cam Vista IM
 
| VF0640
 
| VF0640
 
|
 
|
| Raspbian
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| works on Raspbian at 320x240 resolution, 15fps
 
| works on Raspbian at 320x240 resolution, 15fps
Line 54: Line 59:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| Detects, untested.
 
| Detects, untested.
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Creative
 +
|Webcam Pro
 +
| PD1030
 +
|
 +
|
 +
|
 +
|
 +
|  ov519 driver crashes almost immediately. ("gspca: ISOC data error: [0] len=0, status=-4004")
 +
  
 
|- valign="top" align="left" style="background: #F5FAFF;"
 
|- valign="top" align="left" style="background: #F5FAFF;"
Line 65: Line 82:
 
|  
 
|  
 
|  
 
|  
 +
|
  
|- valign="top" align="left" style="background: #F5FAFF;"
+
|- valign="top" align="left" style="background: #F6D2CF;"
 
|HP
 
|HP
 
|Webcam HP-3100
 
|Webcam HP-3100
Line 72: Line 90:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| UVCVideo /dev/video0 Needs chmod to 666 to operate. Will work without hub if only device in USB ports. Works with both Arch and Wheezy out of the box
 
| UVCVideo /dev/video0 Needs chmod to 666 to operate. Will work without hub if only device in USB ports. Works with both Arch and Wheezy out of the box
Line 80: Line 99:
 
| V-U0013
 
| V-U0013
 
|
 
|
| 2012-08-16-Wheezy-raspbian
+
| raspbian/wheezy
 +
| 2012-08-16
 
|  
 
|  
 
| works fine without powered hub
 
| works fine without powered hub
Line 87: Line 107:
 
|Logitech
 
|Logitech
 
|Webcam C200
 
|Webcam C200
 +
|
 +
| 046d:0802
 
|  
 
|  
 
|
 
|
|
 
 
|  
 
|  
 
|  
 
|  
Line 97: Line 118:
 
|Webcam C270
 
|Webcam C270
 
|  
 
|  
 +
|
 
|
 
|
 
|  
 
|  
Line 106: Line 128:
 
|Webcam C310
 
|Webcam C310
 
|  
 
|  
 +
|
 
|
 
|
 
|  
 
|  
Line 117: Line 140:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
|  
 
|  
Line 124: Line 148:
 
|Webcam C525
 
|Webcam C525
 
|  
 
|  
 +
|
 
|
 
|
 
|  
 
|  
Line 135: Line 160:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| Works fine without powered hub
 
| Works fine without powered hub
Line 144: Line 170:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| With external power, is uncvideo
 
| With external power, is uncvideo
Line 152: Line 179:
 
|  
 
|  
 
|
 
|
| Raspbian
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| With powered hub, detected out of box as Video0 V4L device
 
| With powered hub, detected out of box as Video0 V4L device
Line 162: Line 190:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| Works with external power
 
| Works with external power
Line 170: Line 199:
 
|  
 
|  
 
|
 
|
| Debian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| Powered by RasPi
 
| Powered by RasPi
  
|- valign="top" align="left" style="background: #F5FAFF;"
+
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Logitech
 +
|Webcam Pro 4000
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| It uses pwc driver which does not work. Maybe it's because of general Raspberry Pi USB bug.
 +
 
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 
|Logitech
 
|Logitech
 
|Webcam Pro 9000
 
|Webcam Pro 9000
Line 180: Line 220:
 
| 046d:0809
 
| 046d:0809
 
| Arch Linux
 
| Arch Linux
 +
|
 
|  
 
|  
| Powered by RasPi, measured ~120 mA current capturing at ~5fps
+
| Powered by RasPi, measured ~120 mA current capturing at ~5fps. Has issues capturing images at higher than default resolutions (using motion - Arch and Debian).
  
 
|- valign="top" align="left" style="background: #F5FAFF;"
 
|- valign="top" align="left" style="background: #F5FAFF;"
Line 188: Line 229:
 
| MD86511
 
| MD86511
 
|
 
|
| 2012-07-15-Wheezy-raspbian
+
| raspbian/wheezy
 +
| 2012-07-15
 
|  
 
|  
 
| Powered by RasPi
 
| Powered by RasPi
Line 197: Line 239:
 
| H5D-00001
 
| H5D-00001
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
|  
 
|  
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Microsoft
 +
|LifeCam HD-5000
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| Picture breaks up at the bottom
  
 
|- valign="top" align="left" style="background: #F5FAFF;"
 
|- valign="top" align="left" style="background: #F5FAFF;"
Line 206: Line 259:
 
|  
 
|  
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy 
 +
|
 
|  
 
|  
 
| Powered by USB hub
 
| Powered by USB hub
Line 215: Line 269:
 
| NX-6000
 
| NX-6000
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| Powered by USB hub
 
| Powered by USB hub
Line 224: Line 279:
 
| VX-7000
 
| VX-7000
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| Powered by USB hub
 
| Powered by USB hub
  
|- valign="top" align="left" style="background: #F5FAFF;"
+
|- valign="top" align="left" style="background: #F6D2CF;"
 
|Microsoft
 
|Microsoft
 
|LifeCam
 
|LifeCam
 
| VX-3000
 
| VX-3000
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| There do appear to be some issues with image quality and getting partial frames and such, with fswebcam
 
| There do appear to be some issues with image quality and getting partial frames and such, with fswebcam
Line 242: Line 299:
 
| NX-6000
 
| NX-6000
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| Powered by USB hub
 
| Powered by USB hub
  
|- valign="top" align="left" style="background: #F5FAFF;"
+
|- valign="top" align="left" style="background: #F6D2CF;"
 
|Microsoft
 
|Microsoft
 
|LifeCam
 
|LifeCam
 
| VX-800
 
| VX-800
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
| 352*288
+
|
 +
| 352x288
 
| Doesn't work at full resolution
 
| Doesn't work at full resolution
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Microsoft
 +
|LifeCam Studio/Cinema
 +
|
 +
|
 +
|
 +
|
 +
|
 +
| Has UVC issues detailed here [http://www.ideasonboard.org/uvc/#devices]. Horizontal lines problem [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=12304]. Stability issues [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=12247].
  
 
|- valign="top" align="left" style="background: #F5FAFF;"
 
|- valign="top" align="left" style="background: #F5FAFF;"
Line 260: Line 329:
 
|  
 
|  
 
| 045e:0294
 
| 045e:0294
| Arch
+
| Arch Linux
 +
|
 
|  
 
|  
 
| Powered by RasPi
 
| Powered by RasPi
  
|- valign="top" align="left" style="background: #F5FAFF;"
+
|- valign="top" align="left" style="background: #F6D2CF;"
 
|Sony
 
|Sony
 
| Playstation Eye for PS3
 
| Playstation Eye for PS3
Line 270: Line 340:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| The occasional frame is corrupted/stutters when running at 640x480
 
| The occasional frame is corrupted/stutters when running at 640x480
Line 277: Line 348:
 
| Playstation Eye for PS2
 
| Playstation Eye for PS2
 
|  
 
|  
 +
|
 
|
 
|
 
|  
 
|  
 
|  
 
|  
 
| Occasional 'mangled frame' directly connected to Rev 2 Raspberry P
 
| Occasional 'mangled frame' directly connected to Rev 2 Raspberry P
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Sony
 +
| Playstation Eye for PS2
 +
| SLEH 00030
 +
|
 +
| Arch Linux
 +
|
 +
|
 +
| (OV519 camera). Picture constantly breaks up on xawtv and wxcam under Arch Linux. Noted there were ISOC data error len=0 status=-4004 errors in dmesg. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB hub. Arch was updated on 17th July 2012
  
 
|- valign="top" align="left" style="background: #F5FAFF;"
 
|- valign="top" align="left" style="background: #F5FAFF;"
Line 288: Line 370:
 
|
 
|
 
| Arch Linux
 
| Arch Linux
 +
|
 
|  
 
|  
 
| works out of the box
 
| works out of the box
 +
 +
|- valign="top" align="left" style="background: #F6D2CF;"
 +
|Trust
 +
| SPACEC@M 200
 +
|
 +
|
 +
| Arch Linux
 +
|
 +
|
 +
| (OV511 camera). Picture stops after a few seconds in xawtv under Arch Linux and xawtv reports libv4l2 errors. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB Hub. Arch was updated on 17th July 2012
 +
  
 
|-
 
|-
 
|}
 
|}

Latest revision as of 13:27, 7 December 2012

USB Webcams

Brand Name Model Number Hardware ID Verified OS Verified OS version Verified Resolution Additional Information


Canyon CNR-WCAM820 raspbian/wheezy 1280x1024 2 Mpixel camera with manual focus; works with fswebcam and v4l4j on Raspbian Wheezy armhf; problems with 1600x1200 resolution in some apps (timeouts - probably too slow USB); 1280x1024 and lower resolutions works OK
Creative Live! VF0470 ArchLinux works out of the box on ArchLinux
Creative Live! Cam Socialize HD VF0610 041e:4080 raspbian/wheezy 2012-11-26 960x544 Works at 1280x720 taking stills in fswebcam with some errors using MJPEG, unusable with YUYV. 960x544 works in both MJPEG and YUYV. Has some stabilitiy issues if powered from RasPi (Drops USB +eth0 every 8 or so hours). Helps to append nodrop=1 and timeout=5000 to uvcvideo module.
Creative Live! Cam Vista IM VF0640 raspbian/wheezy works on Raspbian at 320x240 resolution, 15fps
Creative Webcam Notebook PD1170 Detects, untested.
Creative Webcam Pro PD1030 ov519 driver crashes almost immediately. ("gspca: ISOC data error: [0] len=0, status=-4004")


HP WebcamHD-2200 HD-2200
HP Webcam HP-3100 HP-3100 UVCVideo /dev/video0 Needs chmod to 666 to operate. Will work without hub if only device in USB ports. Works with both Arch and Wheezy out of the box
Logitech Webcam C100 V-U0013 raspbian/wheezy 2012-08-16 works fine without powered hub
Logitech Webcam C200 046d:0802
Logitech Webcam C270 With external power
Logitech Webcam C310 Does not require a powered hub to capture snapshots
Logitech Webcam C510
Logitech Webcam C525 Works fine without powered hub
Logitech Webcam C615 Works fine without powered hub
Logitech Webcam C910 With external power, is uncvideo
Logitech Webcam C920 raspbian/wheezy With powered hub, detected out of box as Video0 V4L device
Logitech QuickCam Orbit/Sphere Works with external power
Logitech QuickCam Pro 9000 raspbian/wheezy Powered by RasPi
Logitech Webcam Pro 4000 It uses pwc driver which does not work. Maybe it's because of general Raspberry Pi USB bug.
Logitech Webcam Pro 9000 046d:0809 Arch Linux Powered by RasPi, measured ~120 mA current capturing at ~5fps. Has issues capturing images at higher than default resolutions (using motion - Arch and Debian).
Medion MD86511 raspbian/wheezy 2012-07-15 Powered by RasPi
Microsoft LifeCam Cinemap 720p USB HD Webcam H5D-00001 raspbian/wheezy
Microsoft LifeCam HD-5000 Picture breaks up at the bottom
Microsoft LifeCam HD-6000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam NX-6000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam VX-7000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam VX-3000 raspbian/wheezy There do appear to be some issues with image quality and getting partial frames and such, with fswebcam
Microsoft LifeCam NX-6000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam VX-800 raspbian/wheezy 352x288 Doesn't work at full resolution
Microsoft LifeCam Studio/Cinema Has UVC issues detailed here [1]. Horizontal lines problem [2]. Stability issues [3].
Microsoft Xbox Live Vision 045e:0294 Arch Linux Powered by RasPi
Sony Playstation Eye for PS3 The occasional frame is corrupted/stutters when running at 640x480
Sony Playstation Eye for PS2 Occasional 'mangled frame' directly connected to Rev 2 Raspberry P
Sony Playstation Eye for PS2 SLEH 00030 Arch Linux (OV519 camera). Picture constantly breaks up on xawtv and wxcam under Arch Linux. Noted there were ISOC data error len=0 status=-4004 errors in dmesg. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB hub. Arch was updated on 17th July 2012
Trust 2 MP Auto Focus Webcam Arch Linux works out of the box
Trust SPACEC@M 200 Arch Linux (OV511 camera). Picture stops after a few seconds in xawtv under Arch Linux and xawtv reports libv4l2 errors. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB Hub. Arch was updated on 17th July 2012