Difference between revisions of "User:Maxion"

From eLinux.org
Jump to: navigation, search
(USB Webcams)
(USB Webcams)
 
(One intermediate revision by the same user not shown)
Line 18: Line 18:
 
|CNR-WCAM820
 
|CNR-WCAM820
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
| 2 Mpixel
+
|
 +
| 1280x1024
 
| 2 Mpixel camera with manual focus; works with fswebcam and v4l4j on Raspbian Wheezy armhf; problems with 1600x1200 resolution in some apps (timeouts - probably too slow USB); 1280x1024 and lower resolutions works OK
 
| 2 Mpixel camera with manual focus; works with fswebcam and v4l4j on Raspbian Wheezy armhf; problems with 1600x1200 resolution in some apps (timeouts - probably too slow USB); 1280x1024 and lower resolutions works OK
  
Line 29: Line 30:
 
| ArchLinux
 
| ArchLinux
 
|  
 
|  
 +
|
 
| works out of the box on ArchLinux
 
| works out of the box on ArchLinux
  
Line 36: Line 38:
 
| VF0610
 
| VF0610
 
|041e:4080
 
|041e:4080
| Raspbian Wheezy 2012-11-26
+
| raspbian/wheezy
 +
| 2012-11-26
 
| 960x544
 
| 960x544
 
| Works at 1280x720 taking stills in fswebcam with some errors using MJPEG, unusable with YUYV. 960x544 works in both MJPEG and YUYV. Has some stabilitiy issues if powered from RasPi (Drops USB +eth0 every 8 or so hours). Helps to append nodrop=1 and timeout=5000 to uvcvideo module.
 
| Works at 1280x720 taking stills in fswebcam with some errors using MJPEG, unusable with YUYV. 960x544 works in both MJPEG and YUYV. Has some stabilitiy issues if powered from RasPi (Drops USB +eth0 every 8 or so hours). Helps to append nodrop=1 and timeout=5000 to uvcvideo module.
Line 45: Line 48:
 
| VF0640
 
| VF0640
 
|
 
|
| Raspbian
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| works on Raspbian at 320x240 resolution, 15fps
 
| works on Raspbian at 320x240 resolution, 15fps
Line 55: Line 59:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| Detects, untested.
 
| Detects, untested.
Line 65: Line 70:
 
|  
 
|  
 
|  
 
|  
 +
|
 
|  ov519 driver crashes almost immediately. ("gspca: ISOC data error: [0] len=0, status=-4004")
 
|  ov519 driver crashes almost immediately. ("gspca: ISOC data error: [0] len=0, status=-4004")
  
Line 76: Line 82:
 
|  
 
|  
 
|  
 
|  
 +
|
  
 
|- valign="top" align="left" style="background: #F6D2CF;"
 
|- valign="top" align="left" style="background: #F6D2CF;"
Line 83: Line 90:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| UVCVideo /dev/video0 Needs chmod to 666 to operate. Will work without hub if only device in USB ports. Works with both Arch and Wheezy out of the box
 
| UVCVideo /dev/video0 Needs chmod to 666 to operate. Will work without hub if only device in USB ports. Works with both Arch and Wheezy out of the box
Line 91: Line 99:
 
| V-U0013
 
| V-U0013
 
|
 
|
| 2012-08-16-Wheezy-raspbian
+
| raspbian/wheezy
 +
| 2012-08-16
 
|  
 
|  
 
| works fine without powered hub
 
| works fine without powered hub
Line 98: Line 107:
 
|Logitech
 
|Logitech
 
|Webcam C200
 
|Webcam C200
 +
|
 +
| 046d:0802
 
|  
 
|  
 
|
 
|
|
 
 
|  
 
|  
 
|  
 
|  
Line 108: Line 118:
 
|Webcam C270
 
|Webcam C270
 
|  
 
|  
 +
|
 
|
 
|
 
|  
 
|  
Line 117: Line 128:
 
|Webcam C310
 
|Webcam C310
 
|  
 
|  
 +
|
 
|
 
|
 
|  
 
|  
Line 128: Line 140:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
|  
 
|  
Line 135: Line 148:
 
|Webcam C525
 
|Webcam C525
 
|  
 
|  
 +
|
 
|
 
|
 
|  
 
|  
Line 146: Line 160:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| Works fine without powered hub
 
| Works fine without powered hub
Line 155: Line 170:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| With external power, is uncvideo
 
| With external power, is uncvideo
Line 163: Line 179:
 
|  
 
|  
 
|
 
|
| Raspbian
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| With powered hub, detected out of box as Video0 V4L device
 
| With powered hub, detected out of box as Video0 V4L device
Line 173: Line 190:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| Works with external power
 
| Works with external power
Line 181: Line 199:
 
|  
 
|  
 
|
 
|
| Debian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| Powered by RasPi
 
| Powered by RasPi
Line 189: Line 208:
 
|Webcam Pro 4000
 
|Webcam Pro 4000
 
|  
 
|  
 +
|
 
|  
 
|  
 
|  
 
|  
Line 200: Line 220:
 
| 046d:0809
 
| 046d:0809
 
| Arch Linux
 
| Arch Linux
 +
|
 
|  
 
|  
 
| Powered by RasPi, measured ~120 mA current capturing at ~5fps. Has issues capturing images at higher than default resolutions (using motion - Arch and Debian).
 
| Powered by RasPi, measured ~120 mA current capturing at ~5fps. Has issues capturing images at higher than default resolutions (using motion - Arch and Debian).
Line 208: Line 229:
 
| MD86511
 
| MD86511
 
|
 
|
| 2012-07-15-Wheezy-raspbian
+
| raspbian/wheezy
 +
| 2012-07-15
 
|  
 
|  
 
| Powered by RasPi
 
| Powered by RasPi
Line 217: Line 239:
 
| H5D-00001
 
| H5D-00001
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
|  
 
|  
Line 227: Line 250:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| Picture breaks up at the bottom
 
| Picture breaks up at the bottom
Line 235: Line 259:
 
|  
 
|  
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy 
 +
|
 
|  
 
|  
 
| Powered by USB hub
 
| Powered by USB hub
Line 244: Line 269:
 
| NX-6000
 
| NX-6000
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| Powered by USB hub
 
| Powered by USB hub
Line 253: Line 279:
 
| VX-7000
 
| VX-7000
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| Powered by USB hub
 
| Powered by USB hub
Line 262: Line 289:
 
| VX-3000
 
| VX-3000
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| There do appear to be some issues with image quality and getting partial frames and such, with fswebcam
 
| There do appear to be some issues with image quality and getting partial frames and such, with fswebcam
Line 271: Line 299:
 
| NX-6000
 
| NX-6000
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
 +
|
 
|  
 
|  
 
| Powered by USB hub
 
| Powered by USB hub
Line 280: Line 309:
 
| VX-800
 
| VX-800
 
|
 
|
| Raspbian Wheezy
+
| raspbian/wheezy
| 352*288
+
|
 +
| 352x288
 
| Doesn't work at full resolution
 
| Doesn't work at full resolution
  
Line 290: Line 320:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| Has UVC issues detailed here [http://www.ideasonboard.org/uvc/#devices]. Horizontal lines problem [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=12304]. Stability issues [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=12247].
 
| Has UVC issues detailed here [http://www.ideasonboard.org/uvc/#devices]. Horizontal lines problem [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=12304]. Stability issues [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=12247].
Line 298: Line 329:
 
|  
 
|  
 
| 045e:0294
 
| 045e:0294
| Arch
+
| Arch Linux
 +
|
 
|  
 
|  
 
| Powered by RasPi
 
| Powered by RasPi
Line 308: Line 340:
 
|
 
|
 
|  
 
|  
 +
|
 
|  
 
|  
 
| The occasional frame is corrupted/stutters when running at 640x480
 
| The occasional frame is corrupted/stutters when running at 640x480
Line 315: Line 348:
 
| Playstation Eye for PS2
 
| Playstation Eye for PS2
 
|  
 
|  
 +
|
 
|
 
|
 
|  
 
|  
Line 326: Line 360:
 
|
 
|
 
| Arch Linux
 
| Arch Linux
 +
|
 
|  
 
|  
 
| (OV519 camera). Picture constantly breaks up on xawtv and wxcam under Arch Linux. Noted there were ISOC data error len=0 status=-4004 errors in dmesg. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB hub. Arch was updated on 17th July 2012
 
| (OV519 camera). Picture constantly breaks up on xawtv and wxcam under Arch Linux. Noted there were ISOC data error len=0 status=-4004 errors in dmesg. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB hub. Arch was updated on 17th July 2012
Line 335: Line 370:
 
|
 
|
 
| Arch Linux
 
| Arch Linux
 +
|
 
|  
 
|  
 
| works out of the box
 
| works out of the box
Line 344: Line 380:
 
|
 
|
 
| Arch Linux
 
| Arch Linux
 +
|
 
|  
 
|  
 
| (OV511 camera). Picture stops after a few seconds in xawtv under Arch Linux and xawtv reports libv4l2 errors. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB Hub. Arch was updated on 17th July 2012
 
| (OV511 camera). Picture stops after a few seconds in xawtv under Arch Linux and xawtv reports libv4l2 errors. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB Hub. Arch was updated on 17th July 2012

Latest revision as of 13:27, 7 December 2012

USB Webcams

Brand Name Model Number Hardware ID Verified OS Verified OS version Verified Resolution Additional Information


Canyon CNR-WCAM820 raspbian/wheezy 1280x1024 2 Mpixel camera with manual focus; works with fswebcam and v4l4j on Raspbian Wheezy armhf; problems with 1600x1200 resolution in some apps (timeouts - probably too slow USB); 1280x1024 and lower resolutions works OK
Creative Live! VF0470 ArchLinux works out of the box on ArchLinux
Creative Live! Cam Socialize HD VF0610 041e:4080 raspbian/wheezy 2012-11-26 960x544 Works at 1280x720 taking stills in fswebcam with some errors using MJPEG, unusable with YUYV. 960x544 works in both MJPEG and YUYV. Has some stabilitiy issues if powered from RasPi (Drops USB +eth0 every 8 or so hours). Helps to append nodrop=1 and timeout=5000 to uvcvideo module.
Creative Live! Cam Vista IM VF0640 raspbian/wheezy works on Raspbian at 320x240 resolution, 15fps
Creative Webcam Notebook PD1170 Detects, untested.
Creative Webcam Pro PD1030 ov519 driver crashes almost immediately. ("gspca: ISOC data error: [0] len=0, status=-4004")


HP WebcamHD-2200 HD-2200
HP Webcam HP-3100 HP-3100 UVCVideo /dev/video0 Needs chmod to 666 to operate. Will work without hub if only device in USB ports. Works with both Arch and Wheezy out of the box
Logitech Webcam C100 V-U0013 raspbian/wheezy 2012-08-16 works fine without powered hub
Logitech Webcam C200 046d:0802
Logitech Webcam C270 With external power
Logitech Webcam C310 Does not require a powered hub to capture snapshots
Logitech Webcam C510
Logitech Webcam C525 Works fine without powered hub
Logitech Webcam C615 Works fine without powered hub
Logitech Webcam C910 With external power, is uncvideo
Logitech Webcam C920 raspbian/wheezy With powered hub, detected out of box as Video0 V4L device
Logitech QuickCam Orbit/Sphere Works with external power
Logitech QuickCam Pro 9000 raspbian/wheezy Powered by RasPi
Logitech Webcam Pro 4000 It uses pwc driver which does not work. Maybe it's because of general Raspberry Pi USB bug.
Logitech Webcam Pro 9000 046d:0809 Arch Linux Powered by RasPi, measured ~120 mA current capturing at ~5fps. Has issues capturing images at higher than default resolutions (using motion - Arch and Debian).
Medion MD86511 raspbian/wheezy 2012-07-15 Powered by RasPi
Microsoft LifeCam Cinemap 720p USB HD Webcam H5D-00001 raspbian/wheezy
Microsoft LifeCam HD-5000 Picture breaks up at the bottom
Microsoft LifeCam HD-6000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam NX-6000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam VX-7000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam VX-3000 raspbian/wheezy There do appear to be some issues with image quality and getting partial frames and such, with fswebcam
Microsoft LifeCam NX-6000 raspbian/wheezy Powered by USB hub
Microsoft LifeCam VX-800 raspbian/wheezy 352x288 Doesn't work at full resolution
Microsoft LifeCam Studio/Cinema Has UVC issues detailed here [1]. Horizontal lines problem [2]. Stability issues [3].
Microsoft Xbox Live Vision 045e:0294 Arch Linux Powered by RasPi
Sony Playstation Eye for PS3 The occasional frame is corrupted/stutters when running at 640x480
Sony Playstation Eye for PS2 Occasional 'mangled frame' directly connected to Rev 2 Raspberry P
Sony Playstation Eye for PS2 SLEH 00030 Arch Linux (OV519 camera). Picture constantly breaks up on xawtv and wxcam under Arch Linux. Noted there were ISOC data error len=0 status=-4004 errors in dmesg. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB hub. Arch was updated on 17th July 2012
Trust 2 MP Auto Focus Webcam Arch Linux works out of the box
Trust SPACEC@M 200 Arch Linux (OV511 camera). Picture stops after a few seconds in xawtv under Arch Linux and xawtv reports libv4l2 errors. This happens when powered from the Raspberry Pi and when powered from a Pluscom USB Hub. Arch was updated on 17th July 2012