Jump to: navigation, search


Here's my current list of tastks, listed by priorty:

Jump in if you have an itch...

Everything i have is here: archive notes


version  - Stable Deb   - Testing Deb  - Remove Archive
Karmic   - (done)       - (done)       - (done)
Lucid    - (Precise)    - (done)       - (Precise)
Maverick - (Quantal)    - (Quantal)    - (Quantal)
Natty    - (Raring)     - (Raring)     - (Raring)
Oneiric  - (Raring + 1) - (Raring + 1) - (Raring + 1)
Precise  - (Raring + 2) - (Raring + 2) - (Raring + 2)
Quantal  - (Raring + 3) - (Raring + 3) - (Raring + 3) 
Raring   - (Raring + 4) - (Raring + 4) - (Raring + 4) 

Lenny - (done(keep 2.6.29)) - (done)  - (Wheezy)
Squeeze - (Wheezy)     - (Wheezy)     - (Jessie)
Wheezy  - (Jessie)     - (Jessie)     - (Jessie + 1)
Jessie  - (Jessie + 1) - (Jessie + 1) - (Jessie + 2)

Everything Else:

2.6.36 - Removed
2.6.37 - Removed (Removed during 3.2-rc's)
2.6.38 - Removed (Removed during 3.3-rc's)
2.6.39 - Removed (Removal during 3.4-rc's)
3.0 - Removed (Removal during 3.5-rc's)
3.1 - Removed (Removal during 3.6-rc's)
3.2 - Removed (Removal during 3.9-rc's) (panda is stable with 3.7)
3.3 - Removed (Removal during 3.8-rc's)
3.4 - Removed (Removal during 3.9-rc's)
3.5 - Older Stable (Beagle only)
3.6 - Old Stable (minus-omap4430) (Lucid/Maverick/Natty/Oneiric/Precise/Quantal/Raring Squeeze/Wheezy/Sid)
3.7 - Stable (Lucid/Oneiric/Precise/Quantal/Raring Squeeze/Wheezy/Sid)
3.8 - (ignored)
3.9 - Development (Quantal/Raring Wheezy/Sid)

Keep Last two RC's at a time..

3.0-rc (Removed during 3.2-rc)
3.1-rc (Removed during 3.3-rc)
3.2-rc (Removed during 3.4-rc)
3.3-rc (Removed during 3.5-rc)
3.4-rc (Removed during 3.6-rc)
3.5-rc (Removed during 3.7-rc)
3.6-rc (Removed during 3.8-rc)
3.7-rc (Removed during 3.9-rc)

Ps: Anything Removed is still in the Archive Mirror:

Simple: Things

Bug List

Maverick, X Session - Console broken

Looks like the omapfb package is broken with xorg..

Maverick is EOF (april 2012), please retest with oneiric/precise.. --RobertCNelson 14:59, 12 June 2012 (UTC)


Upgrade X-loader and U-boot

The content of the following git repo seems to be buggy. mmc card builds fine but after running some errors occur.

git clone git://

After you might get a

Unknown command 'mmcinit' - try 'help'
  • Actually, my script never calls "mmcinit/mmc init" as the new mlo/u-boot will "init" the mmc before loading either boot.scr/uEnv.txt from the mmc and then run the reflash script. --RobertCNelson 13:23, 18 May 2011 (UTC)

BTW: Running on a Rev. C3

I guess this one should be addressed to Rob. But anyway:

Thus you could still follow the instructions of the manual run.

Unfortunately this part is outdated as well for the u-boot which arrived late 2010.

Note: If using the latest version of u-boot note that the commands and parameters might have changed. Thus you might have to use mmc init 0; mmc rescan 0 instead of mmcinit or mmc init 0.

A fatload mmc 0:1 0x80200000 MLO will mostlikely result in something like

MMC: block number 0x1 exceeds max(0x0)
** Can't read from device 0 **

until mmc rescan 0. Such things occur quite often in community forums.

Should the current description be kept on the wiki page since older u-boots are still used? Or will we have to replace the text to make it work with the latest u-boot?

Probably this could be done in parallel when updating and solving the content of the git above?


-- Merkel 10:15, 18 May 2011 (UTC)

  • The script has been working perfectly fine with u-boot 2010 for a good year on both Bx/Cx boards. It assumes the worst possible situation, an un-bootable beagle, so you *must* hold down the user button on power up to enable mmc boot. Anything else is/has-been unreliable because u-boot will changes there commands on any random whim... The updated mlo on the mmc will then load u-boot.bin which will init the mmc with it's own internal "mmc boot" script (so mmc init/mmcinit/etc is not needed). On the Bx we need to use the older 2010 u-boot which will then load boot.scr and reflash/replace mlo/u-boot in memory leaving your u-boot env alone (so you'll probally need to update your boot env..) For the Cx we can use a newer faster u-boot (2011), which also happens to load uEnv.txt first, which will then load boot.scr and do the same. --RobertCNelson 13:32, 18 May 2011 (UTC)
  • Since you got: "Unknown command 'mmcinit' - try 'help'" i'm going to assume you had a much older mlo/u-boot installed previously, if you paste your boot message on and either email me (email listed here ) we could work out where your getting stuck.. --RobertCNelson 13:32, 18 May 2011 (UTC)

Adding the SGX is unclear

Your instructions on adding the SGX acceleration are unclear - you don't specify where all the files you are copying are to come from.

e.g. you say "cp *.so /usr/lib" - but you don't say WHERE you are to issue that command from.

David Hagood 21:57, 3 June 2009 (UTC)

Your choice, either the gfx_rel or the gfx_dbg* directory of the SDK. *really not sure how helpful ti/imgtec would be if we ever found a bug.. ;)

--RobertCNelson 01:46, 4 June 2009 (UTC)

any pre-made images?

It seems a lot easier to put Angstrom on the SD card than Ubuntu--why? Is there any way not to build the rootfs from scratch but rather untar onto the ext3 partition?

There's really two issues, hosting and what is a good generic package for everyone???

File Sizes when tar'ed & 7z'ed

bare-bone base: 47Mb

lxde-desktop: 101Mb
xfce4-desktop: 112Mb
gnome-desktop: 144Mb

xubuntu-desktop: 321Mb
kubuntu-desktop: 357Mb
ubuntu-desktop: 382Mb

I've thought of at-least uploading the bare-bone's to, which is good generic starting point, but it's still almost faster to just build lxde-desktop from scratch. (specially if you are you are using apt-cacher-ng/etc)

--RobertCNelson 13:54, 24 June 2009 (UTC)

It probably is faster to build from scratch--however (as an unfortunate medium-level non-computer professional linux user) it took me 15 hours to compile the full ubuntu-desktop image (is that normal?). For the life of me I could not get the uImage to load from my RevC3 board, no matter how I updated the uboot--however, it finally worked when I copied the MLO and uboot.bin files from my working Angstrom card as the first ones on my reformatted fat32 partition and then downloaded your kernel and renamed it uImage.bin. I'd rather know how to get it working with your instructions but I'm glad it worked. Your instructions are quite clear btw although I couldn't upgrade the kernel or write kernel scripts as I couldn't get that far--the nand just wouldn't read the uImage at all.

Considering the number of packages, 15 hours sounds about right. For reference on my dual opteron, with the full ubuntu repo mirrored it takes roughly 6 hours for ubuntu-desktop. An lxde (lxde, gdm) or xfce4 (xfce4, gdm) minimal desktop takes roughly and hour and a half... Could you pastebin your U-Boot bootup with error, I'm guessing it's the latest with the default environment (printenv) which has been changed by default to look for uImage.bin instead of just uImage (and "mmcinit" has been replaced by "mmc init")..

--RobertCNelson 12:59, 25 June 2009 (UTC)

Basically it just said "unable to read uImage file" but there was nothing special. I tried renaming uImage to uImage.bin but nothing happened. The only thing that worked for me was the combo MLO+uboot.bin+uImage.bin. --Jthiels 19:20, 27 June 2009 (UTC)


I'm not sure where to put this in the page, but adding console-setup-mini to my seed list dramatically improved my boot time. --Rwfowler 16:57, 9 November 2009 (UTC)


Maybe after the Jaunty/Karmic setup section in Build Image?

Replace "Note: For USB WIFI adapters, add package "linux-firmware, wireless-tools" to the --seed WiFi Hints:"

with an new subsection:

Useful Seeds:

console-setup-mini: fast console boot...
linux-firmware, wireless-tools: WiFi Hints:

We don't need to explain every one, just ones that make a nice difference for the board..

PS. I've given some thought about making a meta package such as "ubuntu-desktop" but for the beagle, "beagle-console", "beagle-desktop"

--RobertCNelson 20:41, 9 November 2009 (UTC)


The listed uEnv.txt for the Beagleboard XM is wrong. For one thing, it references a zimage file and the instructions make a uImage file.

I used the following, but I'm sure its non-optimal (it waits for a network, for one thing). Any suggestions?

bootargs=ro elevator=noop vram=12M omapfb.mode=dvi:1280x720MR-16@60 mpurate=500 root=/dev/mmcblk0p2 fixrtc quiet splash uenvcmd=mmc rescan;fatload mmc 0:1 0x80000000 uImage;fatload mmc 0:1 0x81600000 uInitrd;bootm 0x80000000 0x81600000

--Richdrich 08:52, 11 September 2012 (UTC)

Hi Richdrich,

The directions for the "uImage" are for the BeagleBone, and they won't be there long, as I just changed the BeagleBone to use zImage now too. As soon as i finish uploading the new images, i'll remove that reference from the wiki (yeah no more mkimage). ;)

Other then not specifying your console it looks fine, well you have no (rootwait)...

--RobertCNelson 15:08, 11 September 2012 (UTC)

How do I enable veth?

I need to use Linux containers (LXC) in Ubuntu on my BeagleBone. Unfortunately I only get an error message:

sudo lxc-start -n testcontainer1

lxc-start: failed to create veth6RRC5H-vethKRBI3G : Operation not supported

lxc-start: failed to create netdev

lxc-start: failed to create the network

lxc-start: failed to spawn 'testcontainer1'

It seems as if the depending kernel module isn't enabled in the current Ubuntu 14.04 build (it is at least in standard Ubuntu 12.04). I tried to create my own build but wasn't able to find out how to modify the kernel config to set CONFIG_VETH=m.

--XXLRay (talk) 13:02, 16 May 2014 (UTC)

Staging Section


Thread titleRepliesLast modified
The current (August 4) trusty image is really a Debian Whezzy image.207:53, 29 September 2014

The current (August 4) trusty image is really a Debian Whezzy image.

I just tried and found that it was a debian wheezy image instead of the advertized ubuntu image.

The previous image from that download location is working for me though. My apt-get upgrade has just finished successfully.

09:47, 4 August 2014

odd, as all the image generation steps are scripted. I just finished uploading 2014-08-13, and tested every *.img for both ubuntu/debian. They all came out fine, so i wonder why 2014-07-06 didn't work..

14:13, 14 August 2014

Is the Debian probably on your flash/sd card and you try to boot from the other device?

07:53, 29 September 2014