BeagleBone Black Rev B6 - USER LED's will not turn on at all when trying to boot from SD / USB

Jump to: navigation, search

I'm working with BeagleBone Black Rev B6 (Debian) for work.

I would like to make an image of the emmc so I can duplicate the entire project with ease.

I've read multiple pages online describing the process of formatting an SD card, putting it into the BBB whilst powered off, and holding S2 when the board is powered on.

When I do this, the USER LED's do not turn on at all.

I've read this can be caused by not having enough power to the board.

I have tried a number of things to see what the issue:

* I've tested multiple boards (All BBB Rev B6)
* 2 different USB Cables
* 3 different USB ports
* 2 different 5v 1.2a power supplies
* Formatted my 16G SD Card (Came with the BBB) to FAT32 Partition, marked as active
* Copied over the files from the download as instructed
* Different combinations of holding the S2 button upon power on, pressing the reset button, etc etc

I believe that I can make an image of the OS and all the files on the BBB with the dd command, so that is what I will resort to. I will be preparing some 50+ of these BBB's in the coming month, and I would like a very easy and streamlined way of doing all this.

Thanks for the help

11:01, 13 August 2014

Further information:

* I am able to mount and read the SD card from within the OS on the BBB.


* When I am told that the SD card needs to be FAT formatted, is FAT32 sufficient for this? Or should I be using something like FAT16?
11:04, 13 August 2014

@Cjohnweb -- FAT32 worked for me (formatted from a Windows 7 virtual machine).

Initially, I had many failed attempts when I tried to extract the eMMC image. I tried different types of FAT file systems, using different OS's to perform the format, marking the card as 'active' or 'bootable', copying the files to the card in a specific order (so the MLO and u-boot.img files were first in the file allocation table), all to no avail. Eventually, I discovered you have to hold the S2 button while power is applied, and then release the button a few seconds later. Holding the S2 button and pressing RESET did NOT work for me. Holding the S2 button for too long also does not work (the board just turns off).

It all seems painfully simple in hindsight, but when I first read this Wiki article it didn't say anything about the S2 button, and nothing I tried worked. Even when I was holding the S2 button, I was just pressing RESET, which also doesn't work.

Hopefully this helps!

13:29, 12 December 2014