BeagleBox DSP

From eLinux.org
Revision as of 20:33, 10 September 2012 by Mjhammel (talk | contribs) (Created page with "Sites of interest: * http://elinux.org/BeagleBoard/gst-dsp ** https://code.google.com/p/gst-dsp/ - code for gst-dsp * http://elinux.org/BeagleBoard/DSP_Howto * http://elinux.org/...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Sites of interest:

Updated Big Buck Bunny AVI:

Notes:

Based on all this research, it looks like my DSP stuff should just work. Here is what I get when I load the modules and try to run gst-dsp:

# modprobe mailbox
# modprobe bridgedriver
[18704.396209] bridgedriver: module is from the staging directory, the quality is unknown, you have been warned.
[18704.458801] omap_timer omap_timer.5: omap2_dm_timer_set_src: clk_set_parent() to 32k_ck FAILED
[18704.471069] omap_timer omap_timer.6: omap2_dm_timer_set_src: clk_set_parent() to 32k_ck FAILED
[18704.501953] DSP Bridge driver loaded
# gst-launch playbin2 uri=file:///root/big_buck_bunny_480p_surround.avi
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Missing element: AC-3 (ATSC A/52) decoder
WARNING: from element /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0: No decoder available for type
'audio/x-ac3, rate=(int)48000, channels=(int)6'.
Additional debug info:
gsturidecodebin.c(874): unknown_type_cb (): /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0
Missing element: GStreamer element autovideosink
ERROR: from element /GstPlayBin2:playbin20/GstPlaySink:playsink0: The autovideosink element is missing.
Additional debug info:
gstplaysink.c(1383): gen_video_chain (): /GstPlayBin2:playbin20/GstPlaySink:playsink0
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
Freeing pipeline ...