Jetson/L4T/r28.2.1 patches

From eLinux.org
< Jetson‎ | L4T
Revision as of 15:51, 17 June 2020 by Danel (talk | contribs) (Created page with "'''''Camera''''' Fix missing timestamp for vi4 Symptom/observe: can not get the timestamp by v4l2 interface https://devtalk.nvidia.com/default/topic/1020202/jetson-tx1/v4l...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Camera

Fix missing timestamp for vi4
Symptom/observe: can not get the timestamp by v4l2 interface
https://devtalk.nvidia.com/default/topic/1020202/jetson-tx1/v4l2-time-stamp-does-not-work-for-l4t-28-1-jetpack-3-1-/post/5274687/#5274687
Fix FE syncpt wait (observe first 3 green/corruption frames)
Symptom/observe: first few green/corruption frames
https://devtalk.nvidia.com/default/topic/1038067/jetson-tx2/data-error-of-csi-camera-capture-on-jetson-tx2/post/5274769/#5274769
Error handling mechanism for T186 (recovery mechanism)
Symptom/observe: feature implement for T186.
https://devtalk.nvidia.com/default/topic/1037809/jetson-tx2/jetpack3-2-1-tx2-csi-mipi-can-only-get-the-the-first-frame-of-image-but-tx1-works-fine-/post/5272855/#5272855
Fix multiple sources per single session can't launch 4 and above sensors.
Symptom/observe: Argus - Syncing multiple source single session can't open 4 and above sensors.
https://devtalk.nvidia.com/default/topic/1039183/jetson-tx2/argus-syncing-multiple-capture-sessions/post/5287248/#5287248
Fix argus_camera launch failure with CSI-camera + USB-camera
Symptom/observe: CSI-cameras is able to capture with v4l2 or gstreamer, but argus_camera launching failed with USB-camera connected
https://devtalk.nvidia.com/default/topic/1037593/jetson-tx2/argus-with-imx377-and-usb-flir-boson/post/5273705/#5273705
Add low_latency_mode control for latency support.
add "--set-ctrl low_latency_mode=1" to the capture command line.
https://devtalk.nvidia.com/default/topic/1038067/jetson-tx2/data-error-of-csi-camera-capture-on-jetson-tx2/post/5274769/#5274769

Multimedia

[MMAPI]Cannot run NvVideoDecoder in loop/Memory leak in NvVideoEncoder
https://devtalk.nvidia.com/default/topic/1043548/jetson-tx1/-mmapi-please-merge-two-libtegrav4l2-so-that-modify-different-issues/post/5294104/#5294104
[MMAPI]Fail to decode via NvJpegdecoder
https://devtalk.nvidia.com/default/topic/1043325/jetson-tx2/nvjpeg-die-on-decoding-picture/post/5293469/#5293469
[MMAPI]Cannot run nvjpeg encoder on child process
https://devtalk.nvidia.com/default/topic/1043328/jetson-tx2/cannot-run-nvjpeg-encoder-on-child-process/post/5314215/#5314215
[GSTREAMER]Hit segment fault wilie linking nvjpegenc and nvjpegdec
https://devtalk.nvidia.com/default/topic/1066646/jetson-tx2/tx2-sigsegv-with-patched-libnvjpeg-so/post/5403906/#5403906
[GSTREAMER]Memory leak in nvcompositor
https://devtalk.nvidia.com/default/topic/1038242/jetson-tx2/memory-leak-issue-of-gstreamer-1-8-3-in-jetpack-3-2-1/post/5276096/#5276096
[GSTREAMER]fix temporal-tradeoff is not working
https://devtalk.nvidia.com/default/topic/1045487/jetson-tx2/gst-omx-issues-temporal-tradeoff/post/5308049/#5308049

Serial

Fix TTY rt-flush thread not seeing data
Symptom/observe: When using rt-flush on a serial-port, data is only available after 256 bytes have been received
https://devtalk.nvidia.com/default/topic/1066196/jetson-tx2/running-tx2-serial-port-with-rt-flush-possible-bug-and-fix-/

IO

[PIN config] DPx_AUX_CH_xx as i2c function.
https://devtalk.nvidia.com/default/topic/1026087/jetson-tx2/tx2-use-i2c4-dp1_aux_ch-/post/5288257/#5288257
[script for flash multiple device]
https://devtalk.nvidia.com/default/topic/1038136/jetson-tx2/about-flashing-multiple-tegra-devices-/post/5288276/#5288276

TX1 Watchdog

Enable watchdog to reboot got reboot hang sometimes.
https://devtalk.nvidia.com/default/topic/1045090/jetson-tx1/oom-on-jetson-tx1/post/5307030/#5307030