Difference between revisions of "Raspbian"

From eLinux.org
Jump to: navigation, search
(Modified packages)
(Modified packages: rm duplicate, add gcc-4.6)
Line 44: Line 44:
 
| known bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=664930 664930] filed in debian.
 
| known bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=664930 664930] filed in debian.
 
|-
 
|-
| libxslt
+
| rowspan =2 | gcc-4.6
| patched debian/rules
+
| change compiler defaults
| build failed, added nmu
+
| need to build binaries suitable for rpi
| known bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=666333 666333] filed in debian.
+
| permanent raspbian change, not suitable for pushing upstream
 +
|-
 +
| treat wheezy the same as sid
 +
| compiler built in wheezy was passing --as-needed to the linker which we don't want
 +
| bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=670821 670821] filed in debian
 
|}
 
|}

Revision as of 04:52, 29 April 2012


Raspbian is a project to create a hard float port of debian for the Raspberry Pi and similar devices which use ARMv6 processors with VFPv2. The official debian armhf packages are built with ARMv7, VFPv3_D16 and Thumb2. So they are not suitable for the Pi and similar devices. To get arround this we have to change the compiler defaults (easy) and recompile everything (harder than it sounds).

Infrastructure has been set-up for building packages. We aim to stay as close to debian wheezy as possible but we will pull in packages from sid and/or make our own modifications when we deem it nessacery.

A chroot can be bootstrapped from a debian squeeze armel installation using the following commands (replace /chroots/wheezy-armhf-rpi with where you want your chroot).

debootstrap --arch=armhf wheezy /chroots/wheezy-armhf-rpi http://debian.raspbian.com/debian/
cd /chroots/wheezy-armhf-rpi
wget http://debian.raspbian.com/raspbian.public.key
chroot /chroots/wheezy-armhf-rpi
mount -t proc proc /proc
cat raspbian.public.key | apt-key add
apt-get update

Modified packages

Note: this list is incomplete

Source package Changes Reason Status
gettext fixed dependency scanning package had incorrect dependencies bug 670588 filed in debian
libxslt fixed building with build-arch package failed to build with build-arch bug 666333 filed in debian.
elfutils testsuite disabled testsuite failed on plugwash's build system and package was needed local hack, hopefully we can drop later.
openldap patched smbk5pwd.c compilation failed, added nmu known bug 664930 filed in debian.
gcc-4.6 change compiler defaults need to build binaries suitable for rpi permanent raspbian change, not suitable for pushing upstream
treat wheezy the same as sid compiler built in wheezy was passing --as-needed to the linker which we don't want bug 670821 filed in debian