Difference between revisions of "Talk:BeagleBoardUbuntu"

From eLinux.org
Jump to: navigation, search
( not bootable in lucid)
( not bootable in lucid)
Line 7: Line 7:
Everything i have is here: https://launchpad.net/~beagleboard-kernel
Everything i have is here: https://launchpad.net/~beagleboard-kernel
== not bootable in lucid ==
== 2.6.34-rc7-d2 kernel BUG at drivers/video/omap2/dss/core.c:323! ==
Importance: Zippy1/2 detection, NetInstall that supports zippy's..
However Maverick's is, tested a week after Maverick's branch was created..
Lucid: gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5)
Maverick: gcc version 4.4.4 (Ubuntu 4.4.4-1ubuntu1)
== SGX 3_01_00_06 ==
== SGX 3_01_00_06 ==

Revision as of 07:41, 16 May 2010


Here's my current list of tastks, listed by priorty:

Jump in if you have an itch...

Everything i have is here: https://launchpad.net/~beagleboard-kernel

2.6.34-rc7-d2 kernel BUG at drivers/video/omap2/dss/core.c:323!


SGX 3_01_00_06

Status: Buildable, but Broken...

ON Module load:

[  118.482879] PVR: PVRCore_Init
[  118.482910] PVR: Setting Debug Level = 0x4
[  118.483337] PVR_K:(Warning): _SetDispatchTableEntry: There is a gap in the dispatch table between indices 104 (PVRSRV_BRIDGE_SGX_READ_HWPERF_CB) and 102 (PVRSRV_BRIDGE_SGX_SCHEDULE_PROCESS_QUEUES) [2807, /home/voodoo/bzr_repo/2.6-stable/omap3-sgx-modules/services4/srvkm/bridged/bridged_pvr_bridge.c]
[  118.483398] PVR_K:(Error): NOTE: Enabling DEBUG_BRIDGE_KM_DISPATCH_TABLE may help debug this issue. [2814, /home/voodoo/bzr_repo/2.6-stable/omap3-sgx-modules/services4/srvkm/bridged/bridged_pvr_bridge.c]
[  118.492462] PVR: PVRSRVDriverProbe(pDevice=bf117d60)
[  118.492523] PVR_K:(Warning): SysInitialise: Entering... [180, /home/voodoo/bzr_repo/2.6-stable/omap3-sgx-modules/services4/system/omap3630/sysconfig.c]
[  118.492675] PVR: EnableSystemClocks: Enabling System Clocks
[  118.492858] PVR: Setting GPTIMER11 parent to System Clock
[  118.492889] PVR: GPTIMER11 clock is 13MHz
[  118.492919] PVR: Setting GPTIMER11 mode to posted (currently is non-posted)
[  118.492950] PVR: OSUnMapPhysToLin: unmapping 4 bytes from 0xfa088040
[  118.492980] PVR: OSUnMapPhysToLin: unmapping 4 bytes from 0xfa088024
[  118.493072] PVR_K:(Error): EnableSGXClocks: Couldn't set SGX function clock rate (-22) [475, /home/voodoo/bzr_repo/2.6-stable/omap3-sgx-modules/services4/system/omap3630/sysutils_linux.c]
[  118.493103] PVR_K:(Error): SysInitialise: Failed to Enable SGX clocks (1) [336, /home/voodoo/bzr_repo/2.6-stable/omap3-sgx-modules/services4/system/omap3630/sysconfig.c]
[  118.493133] PVR: DisableSystemClocks: Disabling System Clocks
[  118.493164] PVR: OSUnMapPhysToLin: unmapping 4 bytes from 0xfa088024
[  118.493286] PVR: PVRCore_Init: major device 250
[  118.823944] PVR_K:(Fatal): Debug assertion failed! [126, /home/voodoo/bzr_repo/2.6-stable/omap3-sgx-modules/services4/srvkm/common/perproc.c]
[  118.823974] kernel BUG at /home/voodoo/bzr_repo/2.6-stable/omap3-sgx-modules/services4/srvkm/env/linux/pvr_debug.c:239!
[  118.834960] Unable to handle kernel NULL pointer dereference at virtual address 00000000
[  118.843139] pgd = c7f00000
[  118.845916] mmcblk0: retrying using single block read
[  118.845977] [00000000] *pgd=87a16031, *pte=00000000, *ppte=00000000
[  118.852600] Internal error: Oops: 817 [#1] PREEMPT
[  118.857391] last sysfs file: /sys/devices/platform/soc-audio/sound/card0/uevent
[  118.864746] Modules linked in: pvrsrvkm arc4 rtl8187 mac80211 cfg80211 rfkill asix eeprom_93cx6 usbhid usbnet rtc_twl mailbox_mach mailbox rtc_core
[  118.878204] CPU: 0    Not tainted  ( #1)
[  118.883117] PC is at __bug+0x1c/0x28
[  118.886718] LR is at __bug+0x18/0x28
[  118.890319] pc : [<c0044f8c>]    lr : [<c0044f88>]    psr: 40000013
[  118.890319] sp : c70efde0  ip : c70efd58  fp : 00000002
[  118.901885] r10: c72ac140  r9 : c70ee000  r8 : c7fb6c40
[  118.907135] r7 : c717e8c0  r6 : c70ee000  r5 : 00000000  r4 : 00000001
[  118.913696] r3 : 00000000  r2 : c70ee000  r1 : c70ee000  r0 : 00000081
[  118.920257] Flags: nZcv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
[  118.927429] Control: 10c5387d  Table: 87f00019  DAC: 00000015
[  118.933227] Process pvrsrvinit (pid: 738, stack limit = 0xc70ee2f0)
[  118.939514] Stack: (0xc70efde0 to 0xc70f0000)
[  118.943908] fde0: bf0ea4d0 bf0ea4dc 0000007e bf10a504 00000000 bf0d5360 c70efef8 c70ee000
[  118.952148] fe00: c7fb6c40 000002e2 c717e8c0 c02eb420 c717e8c0 00000000 c7193140 bf0e0c08
[  118.960388] fe20: 0fa00000 000002e2 c717e8c0 bf0efc64 c70efe64 c7811c00 c72ac140 c7fb6c40
[  118.968597] fe40: 00000000 c70ee000 00000000 fffffff4 00000002 000002e2 c00f52d8 c00f5330
[  118.976837] fe60: 00000000 00000000 00000002 c72ac140 00000000 c7fb6c40 c780dec0 c7753b98
[  118.985076] fe80: c00f5208 c00f0060 00000000 c72ac140 c724d0c0 ffffff9c c7df3000 00000003
[  118.993316] fea0: c70efef8 c00f02d8 c724d0c0 c00fc688 00000000 00000000 bee068ec c00fefb8
[  119.001525] fec0: 4001e000 c79c2f98 00000000 c70efed8 c02ef30c c051575c 400e3e60 bee068ec
[  119.009765] fee0: c7df3000 ffffff9c c7dc5e90 00000000 c06aa2cc 00000007 c780dec0 c7753b98
[  119.018005] ff00: 400e3e60 00000000 ffffffff 00000000 c7543618 00000101 00000001 00000000
[  119.026214] ff20: c7df3000 40033545 00000fff 00000000 40033545 00001000 c7df3000 c072ade0
[  119.034454] ff40: c0041c24 00000003 00000000 c72ac140 c0109bb8 c051575c c00fcb94 00000002
[  119.042694] ff60: bee068ec ffffff9c c7df3000 00000003 c70ee000 00000000 00000000 c00efe7c
[  119.050933] ff80: 00000026 00000000 bee0676c bee0676c 00000000 00000005 c0041c24 c70ee000
[  119.059143] ffa0: 4001e000 c0041aa0 bee0676c bee0676c 40033545 00000002 bee068ec 4003da08
[  119.067382] ffc0: bee0676c bee0676c 00000000 00000005 00000000 00000000 4001e000 00000000 
[  119.075622] ffe0: bee0676c bee06658 40021be4 400e3e7c 60000010 40033545 31000064 00667562
[  119.084075] [<c0044f8c>] (__bug+0x1c/0x28) from [<bf0ea4dc>] (PVRSRVDebugAssertFail+0x30/0x38 [pvrsrvkm])
[  119.093872] [<bf0ea4dc>] (PVRSRVDebugAssertFail+0x30/0x38 [pvrsrvkm]) from [<bf0d5360>] (PVRSRVPerProcessDataConnect+0x30/0x344 [pvrsrvkm])
[  119.106597] [<bf0d5360>] (PVRSRVPerProcessDataConnect+0x30/0x344 [pvrsrvkm]) from [<bf0e0c08>] (PVRSRVProcessConnect+0x14/0x24 [pvrsrvkm])
[  119.119293] [<bf0e0c08>] (PVRSRVProcessConnect+0x14/0x24 [pvrsrvkm]) from [<bf0efc64>] (PVRSRVOpen+0x34/0xd4 [pvrsrvkm])
[  119.130340] [<bf0efc64>] (PVRSRVOpen+0x34/0xd4 [pvrsrvkm]) from [<c00f5330>] (chrdev_open+0x128/0x1f8)
[  119.139739] [<c00f5330>] (chrdev_open+0x128/0x1f8) from [<c00f0060>] (__dentry_open+0x10c/0x2ac)
[  119.148590] [<c00f0060>] (__dentry_open+0x10c/0x2ac) from [<c00f02d8>] (nameidata_to_filp+0x50/0x58)
[  119.157775] [<c00f02d8>] (nameidata_to_filp+0x50/0x58) from [<c00fefb8>] (do_filp_open+0x6ac/0x9f8)
[  119.166900] [<c00fefb8>] (do_filp_open+0x6ac/0x9f8) from [<c00efe7c>] (do_sys_open+0x68/0x118)
[  119.175567] [<c00efe7c>] (do_sys_open+0x68/0x118) from [<c0041aa0>] (ret_fast_syscall+0x0/0x2c)
[  119.184326] Code: e1a01000 e59f000c eb13309f e3a03000 (e5833000) 
[  119.190612] ---[ end trace 5643c74b2a6d7605 ]---
[  148.022125] PVR_K:(Error): PVRSRVRegisterDCDeviceKM: Failed to get SysData [198, /home/voodoo/bzr_repo/2.6-stable/omap3-sgx-modules/services4/srvkm/common/deviceclass.c]
[  148.037475] omaplfb: OMAPLFB_Init: OMAPLFBInit failed
[  148.079162] PVR_K:(Error): PVRSRVRegisterBCDeviceKM: Failed to get SysData [372, /home/voodoo/bzr_repo/2.6-stable/omap3-sgx-modules/services4/srvkm/common/deviceclass.c]
[  148.094818] bccat: can't register BC service 0


dsplink: last tested didn't build... dspbridge: last tested modules built and loaded..

Firmware: etc... builds, but not able to load correctly..


Rob's todo:

Adding/Testing Update MLO/xloader to 1.4.2.

--RobertCNelson 21:26, 5 March 2009 (UTC)

It is easier just to do BOTH "nand ecc sw" and "nandecc sw" to avoid mistakes where someone doesn't use the right one for their u-boot. Doing the "wrong" one won't hurt.--Jkridner 03:16, 10 March 2009 (UTC)

Adding the SGX is unclear

Your instructions on adding the SGX acceleration are unclear - you don't specify where all the files you are copying are to come from.

e.g. you say "cp *.so /usr/lib" - but you don't say WHERE you are to issue that command from.

David Hagood 21:57, 3 June 2009 (UTC)

Your choice, either the gfx_rel or the gfx_dbg* directory of the SDK. *really not sure how helpful ti/imgtec would be if we ever found a bug.. ;)

--RobertCNelson 01:46, 4 June 2009 (UTC)

any pre-made images?

It seems a lot easier to put Angstrom on the SD card than Ubuntu--why? Is there any way not to build the rootfs from scratch but rather untar onto the ext3 partition?

There's really two issues, hosting and what is a good generic package for everyone???

File Sizes when tar'ed & 7z'ed

bare-bone base: 47Mb

lxde-desktop: 101Mb
xfce4-desktop: 112Mb
gnome-desktop: 144Mb

xubuntu-desktop: 321Mb
kubuntu-desktop: 357Mb
ubuntu-desktop: 382Mb

I've thought of at-least uploading the bare-bone's to rcn-ee.com, which is good generic starting point, but it's still almost faster to just build lxde-desktop from scratch. (specially if you are you are using apt-cacher-ng/etc)

--RobertCNelson 13:54, 24 June 2009 (UTC)

It probably is faster to build from scratch--however (as an unfortunate medium-level non-computer professional linux user) it took me 15 hours to compile the full ubuntu-desktop image (is that normal?). For the life of me I could not get the uImage to load from my RevC3 board, no matter how I updated the uboot--however, it finally worked when I copied the MLO and uboot.bin files from my working Angstrom card as the first ones on my reformatted fat32 partition and then downloaded your kernel and renamed it uImage.bin. I'd rather know how to get it working with your instructions but I'm glad it worked. Your instructions are quite clear btw although I couldn't upgrade the kernel or write kernel scripts as I couldn't get that far--the nand just wouldn't read the uImage at all.

Considering the number of packages, 15 hours sounds about right. For reference on my dual opteron, with the full ubuntu repo mirrored it takes roughly 6 hours for ubuntu-desktop. An lxde (lxde, gdm) or xfce4 (xfce4, gdm) minimal desktop takes roughly and hour and a half... Could you pastebin your U-Boot bootup with error, I'm guessing it's the latest with the default environment (printenv) which has been changed by default to look for uImage.bin instead of just uImage (and "mmcinit" has been replaced by "mmc init")..

--RobertCNelson 12:59, 25 June 2009 (UTC)

Basically it just said "unable to read uImage file" but there was nothing special. I tried renaming uImage to uImage.bin but nothing happened. The only thing that worked for me was the combo MLO+uboot.bin+uImage.bin. --Jthiels 19:20, 27 June 2009 (UTC)


I'm not sure where to put this in the page, but adding console-setup-mini to my seed list dramatically improved my boot time. --Rwfowler 16:57, 9 November 2009 (UTC)


Maybe after the Jaunty/Karmic setup section in Build Image?

Replace "Note: For USB WIFI adapters, add package "linux-firmware, wireless-tools" to the --seed WiFi Hints: http://elinux.org/BeagleBoardUbuntuNetwork"

with an new subsection:

Useful Seeds:

console-setup-mini: fast console boot...
linux-firmware, wireless-tools: WiFi Hints: http://elinux.org/BeagleBoardUbuntuNetwork

We don't need to explain every one, just ones that make a nice difference for the board..

PS. I've given some thought about making a meta package such as "ubuntu-desktop" but for the beagle, "beagle-console", "beagle-desktop"

--RobertCNelson 20:41, 9 November 2009 (UTC)

Staging Section

Conversion to Ubuntu ti-omap kernel

Testing Images here:


These are based off:


no-uInitrd (we need to boot first to generate the uInitrd)

setenv bootcmd 'mmc init; fatload mmc 0:1 0x80000000 uImage; bootm 0x80000000'
setenv bootargs 'console=ttyS2,115200n8 root=/dev/mmcblk0p2 rootwait ro vram=12M omapfb.mode=dvi:1280x720MR-16@60'


setenv bootcmd 'mmc init; fatload mmc 0:1 0x80000000 uImage; fatload mmc 0:1 0x81600000 uInitrd; bootm 0x80000000 0x81600000'
setenv bootargs 'console=tty0 console=ttyS2,115200n8 root=/dev/mmcblk0p2 rootwait ro vram=12M omapfb.debug=y omapfb.mode=dvi:1280x720MR-16@60'

setup.sh script on fat16 partition:

sudo dpkg -i linux-image-2.6.33-500-omap_2.6.33-500.3_armel.deb

sudo mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ubuntu 10.04" -d ./boot.cmd ./boot.scr
sudo cp -v ./boot.scr ./boot.ini
sudo mkimage -A arm -O linux -T ramdisk -C none -a 0 -e 0 -n initramfs -d /boot/initrd.img-2.6.33-500-omap ./uInitrd

Weird Bug

Affects only Squeeze 4.4.2-9


## Booting kernel from Legacy Image at 80300000 ...
   Image Name:

   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    3492636 Bytes =  3.3 MB
   Load Address: 80008000
   Entry Point:  80008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

Uncompressing Linux...

uncompression error

 -- System halted