Difference between revisions of "Talk:BeagleBoardUbuntu"

From eLinux.org
Jump to: navigation, search
(rcn-ee.net archive notes)
m (rcn-ee.net archive notes: tweak details)
Line 65: Line 65:
Everything Else:
Everything Else:
  2.6.33 - (Plan: Removal during 2.6.37-rc's)
  2.6.33 - (Plan: Removal during 2.6.38-rc's)
  2.6.34 - (Plan: Removal during 2.6.38-rc's)
  2.6.34 - (Plan: Removal during 2.6.39-rc's)
  2.6.35 - Stable
  2.6.35 - Stable
  2.6.36 - Development
  2.6.36 - (skip)
2.6.37 - New Stable
2.6.38 - Development
One RC at a time..
One RC at a time..
Ps: Archive Mirror: http://rcn-ee.homeip.net:81/dl/mirrors/deb/
Ps: Archive Mirror: http://rcn-ee.homeip.net:81/dl/mirrors/deb/

Revision as of 12:50, 31 January 2011


Here's my current list of tastks, listed by priorty:

Jump in if you have an itch...

Everything i have is here: https://launchpad.net/~beagleboard-kernel

BROKEN: Maverick 10.10 Xfce4

Default user: ubuntu pass: temppwd

Built with rootstock trunk (ARM native mode, run directly on beagleboard):

sudo ./rootstock --fqdn omap --imagesize 2G --dist maverick --serial ttyS2 \
--login ubuntu --password temppwd \
--seed ${MINIMAL},xfce4,gdm,xubuntu-gdm-theme,xubuntu-artwork,xserver-xorg-video-omap3 \
--script fixup.sh --components "main universe multiverse" \
--kernel-image http://rcn-ee.net/deb/maverick/v2.6.35.6-l5/linux-image-

fixup.sh: http://rcn-ee.homeip.net:81/dl/updates/omap-image-builder/tools/fixup.sh

Get prebuilt image:

wget http://rcn-ee.net/deb/rootfs/maverick/ubuntu-10.10-xfce4-armel.tar.7z
mirrors (will take some time to update):
wget http://ynezz.ibawizard.net/beagleboard/maverick/ubuntu-10.10-xfce4-armel.tar.7z
wget http://vivaphp.net/beagle/maverick/ubuntu-10.10-xfce4-armel.tar.7z

md5sum: 41fb35675e2afa581ad65b494f32d215 ubuntu-10.10-xfce4-armel.tar.7z

Unpack it: (sudo apt-get install p7zip-full for 7za)

7za x ubuntu-10.10-xfce4-armel.tar.7z
tar xf ubuntu-10.10-xfce4-armel.tar
cd ubuntu-10.10-xfce4-armel

Quick Install script for Beagle Bx, C2/C3/C4, xM A

./setup_sdcard.sh --mmc /dev/sdX --uboot beagle --swap_file 50 (50Mb minimum required)

For Serial Port Users add: (to use default user/pass ubuntu/temppwd)

  • Additional Options
    • --rootfs <ext4 default>
    • --swap_file <swap file size in MB's>
    • --addon <pico>


After creating user, ubiquity will crash, just reboot..
Then after rebooting, on first login make sure to change the drop down from "ubuntu -> xfce session"

rcn-ee.net archive notes


version - Stable Deb - Testing Deb - Remove archive
Jaunty - October 2010 - delete/archive (Natty Release)
Karmic - April 2011 - October 2010 - Natty + 1 Release
Lucid - April 2013 - April 2011 -
Maverick - April 2012 - October 2012
Natty - October 2012 - April 2011

Lenny : Keep 2.6.29 (till squeeze's release)
Squeeze : (Plan: Removal during Squeeze +2 )

Everything Else:

2.6.33 - (Plan: Removal during 2.6.38-rc's)
2.6.34 - (Plan: Removal during 2.6.39-rc's)
2.6.35 - Stable
2.6.36 - (skip)
2.6.37 - New Stable
2.6.38 - Development

One RC at a time..


Ps: Archive Mirror: http://rcn-ee.homeip.net:81/dl/mirrors/deb/

Simple: Things


uboot for igepv2, touchbook


dspbridge: staging tree in 2.6.35-rc's


Rob's todo:

Adding/Testing Update MLO/xloader to 1.4.2.

--RobertCNelson 21:26, 5 March 2009 (UTC)

It is easier just to do BOTH "nand ecc sw" and "nandecc sw" to avoid mistakes where someone doesn't use the right one for their u-boot. Doing the "wrong" one won't hurt.--Jkridner 03:16, 10 March 2009 (UTC)

Adding the SGX is unclear

Your instructions on adding the SGX acceleration are unclear - you don't specify where all the files you are copying are to come from.

e.g. you say "cp *.so /usr/lib" - but you don't say WHERE you are to issue that command from.

David Hagood 21:57, 3 June 2009 (UTC)

Your choice, either the gfx_rel or the gfx_dbg* directory of the SDK. *really not sure how helpful ti/imgtec would be if we ever found a bug.. ;)

--RobertCNelson 01:46, 4 June 2009 (UTC)

any pre-made images?

It seems a lot easier to put Angstrom on the SD card than Ubuntu--why? Is there any way not to build the rootfs from scratch but rather untar onto the ext3 partition?

There's really two issues, hosting and what is a good generic package for everyone???

File Sizes when tar'ed & 7z'ed

bare-bone base: 47Mb

lxde-desktop: 101Mb
xfce4-desktop: 112Mb
gnome-desktop: 144Mb

xubuntu-desktop: 321Mb
kubuntu-desktop: 357Mb
ubuntu-desktop: 382Mb

I've thought of at-least uploading the bare-bone's to rcn-ee.com, which is good generic starting point, but it's still almost faster to just build lxde-desktop from scratch. (specially if you are you are using apt-cacher-ng/etc)

--RobertCNelson 13:54, 24 June 2009 (UTC)

It probably is faster to build from scratch--however (as an unfortunate medium-level non-computer professional linux user) it took me 15 hours to compile the full ubuntu-desktop image (is that normal?). For the life of me I could not get the uImage to load from my RevC3 board, no matter how I updated the uboot--however, it finally worked when I copied the MLO and uboot.bin files from my working Angstrom card as the first ones on my reformatted fat32 partition and then downloaded your kernel and renamed it uImage.bin. I'd rather know how to get it working with your instructions but I'm glad it worked. Your instructions are quite clear btw although I couldn't upgrade the kernel or write kernel scripts as I couldn't get that far--the nand just wouldn't read the uImage at all.

Considering the number of packages, 15 hours sounds about right. For reference on my dual opteron, with the full ubuntu repo mirrored it takes roughly 6 hours for ubuntu-desktop. An lxde (lxde, gdm) or xfce4 (xfce4, gdm) minimal desktop takes roughly and hour and a half... Could you pastebin your U-Boot bootup with error, I'm guessing it's the latest with the default environment (printenv) which has been changed by default to look for uImage.bin instead of just uImage (and "mmcinit" has been replaced by "mmc init")..

--RobertCNelson 12:59, 25 June 2009 (UTC)

Basically it just said "unable to read uImage file" but there was nothing special. I tried renaming uImage to uImage.bin but nothing happened. The only thing that worked for me was the combo MLO+uboot.bin+uImage.bin. --Jthiels 19:20, 27 June 2009 (UTC)


I'm not sure where to put this in the page, but adding console-setup-mini to my seed list dramatically improved my boot time. --Rwfowler 16:57, 9 November 2009 (UTC)


Maybe after the Jaunty/Karmic setup section in Build Image?

Replace "Note: For USB WIFI adapters, add package "linux-firmware, wireless-tools" to the --seed WiFi Hints: http://elinux.org/BeagleBoardUbuntuNetwork"

with an new subsection:

Useful Seeds:

console-setup-mini: fast console boot...
linux-firmware, wireless-tools: WiFi Hints: http://elinux.org/BeagleBoardUbuntuNetwork

We don't need to explain every one, just ones that make a nice difference for the board..

PS. I've given some thought about making a meta package such as "ubuntu-desktop" but for the beagle, "beagle-console", "beagle-desktop"

--RobertCNelson 20:41, 9 November 2009 (UTC)

Staging Section

Weird Bug

Affects only Squeeze 4.4.2-9


## Booting kernel from Legacy Image at 80300000 ...
   Image Name:

   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    3492636 Bytes =  3.3 MB
   Load Address: 80008000
   Entry Point:  80008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

Uncompressing Linux...

uncompression error

 -- System halted