Revision as of 10:17, 12 July 2010 by RobertCNelson (talk | contribs) (Tasks: add archive notes...)
Jump to: navigation, search


Here's my current list of tastks, listed by priorty:

Jump in if you have an itch...

Everything i have is here: archive notes

Kernel: hasty - delete/archive august 2010

Lenny : Keep 2.6.29 (till squeeze's release)

Everything Else:


One RC at a time..

Simple: Things

Move boot scripts into script
fdisk -l is picking up bad /dev/ devices, should ignore them..
pico, tv, dvi options for uboot

Broken: Lucid 10.04 Xfce4

fix by: #10.04.1 : July 29th

Broken: gdm defaults to xterm, gdm no user's shown...

Notes: 2GB+ SD card, boot scripts are stored in first partition..

Give it time, it'll take 1-2 minutes to load oem-config the first time... (watch the led's)

Built with: (RootStock + lots of tweaks)


Get prebuilt image:

mirrors (will take some time to update):

md5sum: e9be639e03c18e9b766504ab648d8993 ubuntu-10.04-xfce4-armel.tar.7z

Unpack it: (sudo apt-get install p7zip-full for 7za)

7za x ubuntu-10.04-xfce4-armel.tar.7z
tar xf ubuntu-10.04-xfce4-armel.tar
cd ubuntu-10.04-xfce4-armel

Quick Install script for Beagle Bx, C2/C3/C4

./ --mmc /dev/sdX --uboot beagle --swap_file 100

Required Options

  • --swap_file 100 (atleast 100MB's, otherwise oem-config will run out of memory and crash etc..)

Additional Options

  • --rootfs <ext3 default> (ext3/ext4/btrfs)

Known Problem

  • oem-config needs swap, “–swap_file 100″
  • gdm theme doesn’t scale correctly to login: select “auto login” during user configuration
  • Network Manger loads in background but a doesn’t seem to load a xfce4 gui: “sudo nm-applet”


dspbridge: staging tree in 2.6.35-rc's


Rob's todo:

Adding/Testing Update MLO/xloader to 1.4.2.

--RobertCNelson 21:26, 5 March 2009 (UTC)

It is easier just to do BOTH "nand ecc sw" and "nandecc sw" to avoid mistakes where someone doesn't use the right one for their u-boot. Doing the "wrong" one won't hurt.--Jkridner 03:16, 10 March 2009 (UTC)

Adding the SGX is unclear

Your instructions on adding the SGX acceleration are unclear - you don't specify where all the files you are copying are to come from.

e.g. you say "cp *.so /usr/lib" - but you don't say WHERE you are to issue that command from.

David Hagood 21:57, 3 June 2009 (UTC)

Your choice, either the gfx_rel or the gfx_dbg* directory of the SDK. *really not sure how helpful ti/imgtec would be if we ever found a bug.. ;)

--RobertCNelson 01:46, 4 June 2009 (UTC)

any pre-made images?

It seems a lot easier to put Angstrom on the SD card than Ubuntu--why? Is there any way not to build the rootfs from scratch but rather untar onto the ext3 partition?

There's really two issues, hosting and what is a good generic package for everyone???

File Sizes when tar'ed & 7z'ed

bare-bone base: 47Mb

lxde-desktop: 101Mb
xfce4-desktop: 112Mb
gnome-desktop: 144Mb

xubuntu-desktop: 321Mb
kubuntu-desktop: 357Mb
ubuntu-desktop: 382Mb

I've thought of at-least uploading the bare-bone's to, which is good generic starting point, but it's still almost faster to just build lxde-desktop from scratch. (specially if you are you are using apt-cacher-ng/etc)

--RobertCNelson 13:54, 24 June 2009 (UTC)

It probably is faster to build from scratch--however (as an unfortunate medium-level non-computer professional linux user) it took me 15 hours to compile the full ubuntu-desktop image (is that normal?). For the life of me I could not get the uImage to load from my RevC3 board, no matter how I updated the uboot--however, it finally worked when I copied the MLO and uboot.bin files from my working Angstrom card as the first ones on my reformatted fat32 partition and then downloaded your kernel and renamed it uImage.bin. I'd rather know how to get it working with your instructions but I'm glad it worked. Your instructions are quite clear btw although I couldn't upgrade the kernel or write kernel scripts as I couldn't get that far--the nand just wouldn't read the uImage at all.

Considering the number of packages, 15 hours sounds about right. For reference on my dual opteron, with the full ubuntu repo mirrored it takes roughly 6 hours for ubuntu-desktop. An lxde (lxde, gdm) or xfce4 (xfce4, gdm) minimal desktop takes roughly and hour and a half... Could you pastebin your U-Boot bootup with error, I'm guessing it's the latest with the default environment (printenv) which has been changed by default to look for uImage.bin instead of just uImage (and "mmcinit" has been replaced by "mmc init")..

--RobertCNelson 12:59, 25 June 2009 (UTC)

Basically it just said "unable to read uImage file" but there was nothing special. I tried renaming uImage to uImage.bin but nothing happened. The only thing that worked for me was the combo MLO+uboot.bin+uImage.bin. --Jthiels 19:20, 27 June 2009 (UTC)


I'm not sure where to put this in the page, but adding console-setup-mini to my seed list dramatically improved my boot time. --Rwfowler 16:57, 9 November 2009 (UTC)


Maybe after the Jaunty/Karmic setup section in Build Image?

Replace "Note: For USB WIFI adapters, add package "linux-firmware, wireless-tools" to the --seed WiFi Hints:"

with an new subsection:

Useful Seeds:

console-setup-mini: fast console boot...
linux-firmware, wireless-tools: WiFi Hints:

We don't need to explain every one, just ones that make a nice difference for the board..

PS. I've given some thought about making a meta package such as "ubuntu-desktop" but for the beagle, "beagle-console", "beagle-desktop"

--RobertCNelson 20:41, 9 November 2009 (UTC)

Staging Section

Conversion to Ubuntu ti-omap kernel

Testing Images here:

These are based off:

no-uInitrd (we need to boot first to generate the uInitrd)

setenv bootcmd 'mmc init; fatload mmc 0:1 0x80000000 uImage; bootm 0x80000000'
setenv bootargs 'console=ttyS2,115200n8 root=/dev/mmcblk0p2 rootwait ro vram=12M omapfb.mode=dvi:1280x720MR-16@60'


setenv bootcmd 'mmc init; fatload mmc 0:1 0x80000000 uImage; fatload mmc 0:1 0x81600000 uInitrd; bootm 0x80000000 0x81600000'
setenv bootargs 'console=tty0 console=ttyS2,115200n8 root=/dev/mmcblk0p2 rootwait ro vram=12M omapfb.debug=y omapfb.mode=dvi:1280x720MR-16@60'
boot script on fat16 partition:

sudo dpkg -i linux-image-2.6.33-500-omap_2.6.33-500.3_armel.deb

sudo mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ubuntu 10.04" -d ./boot.cmd ./boot.scr
sudo cp -v ./boot.scr ./boot.ini
sudo mkimage -A arm -O linux -T ramdisk -C none -a 0 -e 0 -n initramfs -d /boot/initrd.img-2.6.33-500-omap ./uInitrd

Weird Bug

Affects only Squeeze 4.4.2-9

## Booting kernel from Legacy Image at 80300000 ...
   Image Name:

   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    3492636 Bytes =  3.3 MB
   Load Address: 80008000
   Entry Point:  80008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

Uncompressing Linux...

uncompression error

 -- System halted