Thread history

Fragment of a discussion from Talk:BeagleBone Black Extracting eMMC contents
Viewing a history listing
Jump to: navigation, search
Time User Activity Comment
No results

@Cjohnweb -- FAT32 worked for me (formatted from a Windows 7 virtual machine).

Initially, I had many failed attempts when I tried to extract the eMMC image. I tried different types of FAT file systems, using different OS's to perform the format, marking the card as 'active' or 'bootable', copying the files to the card in a specific order (so the MLO and u-boot.img files were first in the file allocation table), all to no avail. Eventually, I discovered you have to hold the S2 button while power is applied, and then release the button a few seconds later. Holding the S2 button and pressing RESET did NOT work for me. Holding the S2 button for too long also does not work (the board just turns off).

It all seems painfully simple in hindsight, but when I first read this Wiki article it didn't say anything about the S2 button, and nothing I tried worked. Even when I was holding the S2 button, I was just pressing RESET, which also doesn't work.

Hopefully this helps!

13:29, 12 December 2014