Thread history

Jump to: navigation, search
Time User Activity Comment
11:01, 5 December 2017 Wmat (talk | contribs)

New reply created

(Reply to Flash unsuccessful)
10:53, 5 December 2017 Shimon (talk | contribs)

New reply created

(Reply to Flash unsuccessful)
10:13, 14 June 2016 Wmat (talk | contribs)

New reply created

(Reply to Flash unsuccessful)
10:04, 14 June 2016 Rob1234 (talk | contribs)

New reply created

(Reply to Flash unsuccessful)
07:31, 14 June 2016 Wmat (talk | contribs)

New reply created

(Reply to Flash unsuccessful)
07:15, 14 June 2016 Rob1234 (talk | contribs)

New reply created

(Reply to Flash unsuccessful)
15:42, 2 December 2015 Brghena (talk | contribs)

New reply created

(Reply to Flash unsuccessful)
01:35, 23 July 2015 Ntnumartin (talk | contribs)

New reply created

(Reply to Flash unsuccessful)
06:06, 26 May 2015 Mgeorgia (talk | contribs)

New reply created

(Reply to Flash unsuccessful)
13:39, 20 May 2015 Mgeorgia (talk | contribs)

New thread created


Hi everyone,

I seem to have an issue when flashing a new beaglebone black Rev C. On my "master" beaglebone black Rev. C, I can successfully (I think) clone the disk image to a uSD card. Then, after editing the autostart file appropriately, I plugged the uSD card into the new beaglebone black, and was able to get it to boot and start to clone (USR0 flashing in a non-heartbeat fashion and whatnot). However, the "flashing" process seems to only take like 5 minutes, and once its done and I remove the card and reboot, the beaglebone won't boot up at all. I've tried recloning my master beaglebone multiple times, and making some of the slight variations of edits to the autostart file as recommended in this discussion, but I can't seem to get a bootable image to clone to the fresh beaglebone. Am I doing something wrong? My master beaglebone uses about 3GB of the eMMC, but the cloned image is more like 1GB. I read that you can only clone 2GB, am I getting messed up since I'm trying to clone 3GB? Or is the cloned image only showing up as ~1GB because it's compressed on the fly while it's cloning (I do use the gzip command in the autostart file). What am I doing wrong and why can't I seem to get this to work?


13:39, 20 May 2015


So I was unable to get the flash to work, but I think I figured out in general what was causing the issue. All of the beaglebones I have are Rev. C, however one was from Element14 and is a little older, and the others were just recently purchased from a source other than Element14 (unsure of the actual source, someone else at work bought them). Anyways, I was trying to flash the image from the older Element14 beaglebone to the newer beaglebone and figured that should work since they were all Rev. C beaglebones. I tried all sorts of variations on the clone and flash process, but was never able to get it to work. However, I setup one of the newer beaglebones with the exact same OS, apps, and settings as the Element14 beaglebone, and was able to successfully clone that beaglebone image to another one of the newer beaglebones. I'm not exactly sure what's going on, but I figured this information might be useful to someone else who might be running into similar issues.

Something odd or different must have been going on with the Element14 beaglebone image that, when flashed to the newer beaglebone, was causing it to not boot properly (see the above post). If anyone has any thoughts, I'd definitely love to hear them. Thanks!

06:06, 26 May 2015

I had a similar issue with a new batch of BBB not taking the image. It appears to me that a Rev C is not a Rev C. Or perhaps Rev C only refers to the hardware and not the OS installed. Using fdisk and looking at the partition of the eMMC my old board had 3867MB available (image created with this version). Using the new board the partition reported 3825MB. I found a third board that reported 3925MB. All boards purchased in the last year and a half I think.

So I made my partitions use about 150MB less so maybe it will work for a year or two.

So can anyone explain what is going on and what we need to do?


07:15, 14 June 2016

Interesting. I have to say I've not seen this problem, however, if I understand correctly, cloning is being used to copy the image from a working Rev.C BBB to other Rev.C BBBs? I guess I'm a little confused, as I'm wondering why? If you have a flasher-image on an sdcard, why wouldn't you just use that to flash each Rev.C board?

07:31, 14 June 2016

IN my case and probably others. I have created overlays for a custom cape. Added libraries, software, image etc. I documented it this time, but it took 2 hours to do it. Ok, I was side tracked some, but with cloning you turn it on and wait for the LEDs to stop blinking. Who cares if you get side tracked.

10:04, 14 June 2016

Ah yes, that makes sense. You're right, it should just work. I'm not sure what's going on, hopefully someone from the Beagleboard team can help.

10:13, 14 June 2016

Hi, since I spent two hours figuring out how the backup of the interal emmc storage works, here is how I got it running on a recent REV C BBB from Element14:

  • The SD-card really has to be formatted with FAT16, which is only possible with SD-cards <= 4 GB
  1. * Open a command window and enter diskpart
  2. * Select the SD-card as disk with select disk (list disk shows all disk)
  3. * Enter clear (make really sure, that you selected the SD-card)
  4. * Keep diskpart open
  5. * Open the disk-management in Windows
  6. * Create a new partition with exactly 4048 MB and format it with FAT16
  7. * Go back to diskpart, enter "select partition 1" and afterwards active
  8. * Create a folder "dtds" on the SD-card

Copy am335x-boneblack.dtb into the dtds folder Insert the SD-card into the BBB and just power it up (no need to hold down the S2-button)

The USR0 LED should start blinking in a regular pattern (not the heartbeat pattern)

But now the backup solution works really fine and is perfect to clone a running configuration for the BBB onto further BBBs.

01:35, 23 July 2015

Very Important:

When using the REV C BBB from element14, the folder created should be named "dtbs". The above post has a mistake.

15:42, 2 December 2015

I got a new cards from Embest. This solution isn't works. It mean "Copy the entire content of" not allow me to flash an image.

May be exist an other way?

10:53, 5 December 2017

It's not flashing it's copying. You have to unzip that file either directly to the sdcard or to your hard drive and then copy it to the sdcard.

11:01, 5 December 2017