Flash unsuccessful

Jump to: navigation, search
Revision as of 26 May 2015 at 13:06.
The highlighted comment was created in this revision.

Hi everyone,

I seem to have an issue when flashing a new beaglebone black Rev C. On my "master" beaglebone black Rev. C, I can successfully (I think) clone the disk image to a uSD card. Then, after editing the autostart file appropriately, I plugged the uSD card into the new beaglebone black, and was able to get it to boot and start to clone (USR0 flashing in a non-heartbeat fashion and whatnot). However, the "flashing" process seems to only take like 5 minutes, and once its done and I remove the card and reboot, the beaglebone won't boot up at all. I've tried recloning my master beaglebone multiple times, and making some of the slight variations of edits to the autostart file as recommended in this discussion, but I can't seem to get a bootable image to clone to the fresh beaglebone. Am I doing something wrong? My master beaglebone uses about 3GB of the eMMC, but the cloned image is more like 1GB. I read that you can only clone 2GB, am I getting messed up since I'm trying to clone 3GB? Or is the cloned image only showing up as ~1GB because it's compressed on the fly while it's cloning (I do use the gzip command in the autostart file). What am I doing wrong and why can't I seem to get this to work?

Thanks!

    12:39, 20 May 2015

    UPDATE:

    So I was unable to get the flash to work, but I think I figured out in general what was causing the issue. All of the beaglebones I have are Rev. C, however one was from Element14 and is a little older, and the others were just recently purchased from a source other than Element14 (unsure of the actual source, someone else at work bought them). Anyways, I was trying to flash the image from the older Element14 beaglebone to the newer beaglebone and figured that should work since they were all Rev. C beaglebones. I tried all sorts of variations on the clone and flash process, but was never able to get it to work. However, I setup one of the newer beaglebones with the exact same OS, apps, and settings as the Element14 beaglebone, and was able to successfully clone that beaglebone image to another one of the newer beaglebones. I'm not exactly sure what's going on, but I figured this information might be useful to someone else who might be running into similar issues.

    Something odd or different must have been going on with the Element14 beaglebone image that, when flashed to the newer beaglebone, was causing it to not boot properly (see the above post). If anyone has any thoughts, I'd definitely love to hear them. Thanks!

      05:06, 26 May 2015