How to do I change the USB camera resolution?

Jump to: navigation, search

At the recommendation of this wiki, I purchased a Logitech C615 USB web cam to use with my NVIDIA TK1. My TK1 has Ubuntu 14.04.1 LTS

The camera is capable of 1920x1080, which I have verified using Cheese, as well as: sudo apt-get install luvcview luvcview -d /dev/video0 -L

However, when I run my Python code using OpenCV, the most I can get is 800 x 448. I've tried using the embedded OpenCV that comes with L4T (2.4.13), but several websites specifically indicate that the resolution is fixed at 640 x 480 and that since Feb 1, 2016 NVIDIA is still "working on a fix". https://devtalk.nvidia.com/default/topic/913233/jetson-tk1/-opencv4tegra-changing-camera-resolution-solved-/

Next, I tried a native compile of OpenCV (2.4.8) but I still can't get higher resolutions. http://elinux.org/Jetson/Installing_OpenCV

I tried enabling USB 3.0, but that didn't make a difference. I bought a USB 3.0 hub <-- no luck either. I also tried adding usbcore.usbfs_memory_mb=1000 to the end of extlinux.conf <-- no luck. I also tried adding vmalloc=384M to the end of extlinux.conf <-- no luck. I also tried patching lib4vl as described at this site <-- no luck! https://www.e-consystems.com/Articles/Camera/opencv-jetson-using-13MP-MIPI-camera.asp

I'm running out of options. Has anyone figured out a way to get max resolution out of a USB webcam plugged into the TK1 so that it can be used with Python / OpenCV? I'm a bit disappointed that NVIDIA has all the hype of being the "go-to" platform for computer vision, yet a simple plug-and-play webcam doesn't work right out of the box.

Thanks in advance for your help!

08:26, 21 August 2016

You do not have permission to edit this page, for the following reasons:

  • The action you have requested is limited to users in the group: Users.
  • You must confirm your email address before editing pages. Please set and validate your email address through your user preferences.

You can view and copy the source of this page.

Return to Thread:Talk:Jetson/Cameras/How to do I change the USB camera resolution?/reply.