Can't Modify U-Boot Environment Variables on Updated Firmware

Jump to: navigation, search

I'm not sure if the Renesas engineers are watching these pages to handle support requests. I think you would be better served by asking the question on their board mailing list. See

15:13, 17 July 2017

I have done so. It looks like my problem is similar to the "Firmware update hangs" thread below except that I can actually get the firmware update to happen. The update obviously doesn't work though since U-Boot doesn't load when it should.

00:57, 18 July 2017

You do not have permission to edit this page, for the following reasons:

  • The action you have requested is limited to users in the group: Users.
  • You must confirm your email address before editing pages. Please set and validate your email address through your user preferences.

You can view and copy the source of this page.

Return to Thread:Talk:R-Car/Boards/Yocto-Gen3/Can't Modify U-Boot Environment Variables on Updated Firmware/reply (3).

I'm sorry. The log was completely the same halfway. Have you updated all the files?

- bootparam_sa0.srec
- bl2-h3ulcb.srec
- cert_header_sa6.srec
- bl31-h3ulcb.srec
- tee-h3ulcb.srec
- u-boot-elf.srec
17:50, 18 July 2017

Yes. One thing that wasn't clear to me was where to actually get those files. I've been using the ones that are found in ~/tmp/deploy/images/h3ulcb/ after building yocto. Assuming that's the correct path, I'm going to try rebuilding yocto in case I messed something up in that process.

One possible indication of what the issue is: I looked through the Renesas Device Manual to find a solution and found that in the section on booting the addresses the board boots from are slightly different from those on the e-linux wiki (looking at page 238 in particular). I'm a machine learning guy by trade and my architecture knowledge is rather scant comparatively so maybe this is nothing/not what I thought it means.

23:10, 18 July 2017

Yes, /tmp/deploy/images/h3ulcb is correct path. Please refer to the No13 of

All updating methods are described below. Could you try again?

If "u-boot" still doesn't start up please attach the log when flashing the firmware.

03:03, 21 July 2017

Rebuilding the whole thing from scratch worked. Something must have gone wrong in the initial build because the .dtb file sizes between the two builds were off by a few hundred bytes.

22:38, 22 July 2017