Firmware update hangs

Jump to: navigation, search
Revision as of 6 June 2017 at 08:38.
The highlighted comment was created in this revision.

I got a new WS1.1 Premier starter kit, tried to build 2.19.0 but the kernel was crashing.

Tried to upgrade the firmware, but it failed to download bl2 srec. Now, it is not even booting into u-boot.

I tried downloading the firmware from windows PC (Teraterm) and Linux (minicom), boot params is getting programmed. I can't program none of the other firmware as given in the instructions.

Either it hangs after sending the file (bl2, bl32, cert), or over size error (uboot)

Any inputs to recover the board is welcome.

    09:41, 31 May 2017

    Address of bl2 has been chenged from Yocto v2.17.0. Please check the following page. http://elinux.org/R-Car/Boards/H3SK#Flashing_firmware

      18:39, 4 June 2017

      yeah, following the exact instruction in your link. After downloading the bl2 the mini monitor is stuck.

      I see that the board can boot into SCIF download, is it possible recover the board by this route?

        02:30, 5 June 2017

        I've attached the my log.

        H3 SAMPLE LOADER V1.16 2016.10.24                                                          
         CPU   : AArch64 CA57                                                                      
         DRAM  : LPDDR4 DDR3200 DEVICE: QSPI Flash(S25FS128) at 40MHz DMA                          
         BOOT  : Normal Boot                                                                       
         Backup: DDR Cold Boot                                                                     
                                                                                                   
         jump to 0xE6330000                                                                        
                                                                                                   
        H3 MiniMonitor V0.23 2016.10.24                                                            
         Work Memory SystemRAM (H'E6328000-H'E632FFFF)                                             
        >                                                                                          
        >                                                                                          
        >xls2                                                                                      
        ===== Qspi/HyperFlash writing of Gen3 Board Command =============                          
        Load Program to Spiflash                                                                   
        Writes to any of SPI address.                                                              
        Please select,FlashMemory.                                                                 
           1 : QspiFlash       (U5 : S25FS128S)                                                    
           2 : QspiFlash Board (CN2: S25FL512S)                                                    
           3 : HyperFlash      (SiP internal)                                                      
          Select (1-3)>3                                                                           
         READ ID OK.                                                                               
        Program Top Address & Qspi/HyperFlash Save Address                                         
        ===== Please Input Program Top Address ============                                        
          Please Input : H'e6304000                                                                
                                                                                                   
        ===== Please Input Qspi/HyperFlash Save Address ===                                        
          Please Input : H'40000                                                                   
        Work RAM(H'50000000-H'53FFFFFF) Clear....
        please send ! ('.' & CR stop load)                                                         
        H'00040000-0007FFFF Erasing..Erase Completed 
        SAVE SPI-FLASH....... complete!
        
        ======= Qspi/HyperFlash Save Information  =================
         SpiFlashMemory Stat Address : H'00040000
         SpiFlashMemory End Address  : H'0005B03B
        ===========================================================
        
        >
        

        If you don't solve it please attach your log.

          00:38, 6 June 2017