GPIO access problem with R-Car Starter Kit Pro

Jump to: navigation, search

You do not have permission to edit this page, for the following reasons:

  • The action you have requested is limited to users in the group: Users.
  • You must confirm your email address before editing pages. Please set and validate your email address through your user preferences.

You can view and copy the source of this page.


Return to Thread:Talk:R-Car/Boards/Yocto-Gen3/GPIO access problem with R-Car Starter Kit Pro.


I noticed that you use old version BSP.

Yocto v3.21.0 is latest BSP.

So, could you update BSP to v3.21.0 from v3.9.0.

It may fix this issue.

Y.H. (talk)00:13, 3 April 2020

Thank you for the reply.
I also tried Yocto v3.21.0.
But I was unable to access GPIO.

17:05, 6 April 2020


In generally, we should keep to a correct order of register settings to work correctly.

It is possible to mistake the order, so please try to reverse the order of PFC/GPIO setting.

Sorry, I cannot test it because I don't have verification environment for bare metal application ...

Y.H. (talk)01:34, 8 April 2020

I tried reversing the order of the PFC and GPIO settings and the results were the same.

02:49, 10 April 2020


I think gpio module is initialized in ATF until v2.12.0 at least.

But, for any reasons, it maybe removed.

So, it may work to add to initialize any register (it is clock of modules? , or switch of module?) to your program.

Is it possible to investigate how to initialize gpio module?

Y.H. (talk)19:05, 16 April 2020

I think it will take some time, but I'll investigate how to initialize.

02:45, 22 April 2020