Difference between revisions of "User:IanH"

From eLinux.org
Jump to: navigation, search
Line 7: Line 7:
  
 
-----
 
-----
BlueZ 5.4 build
+
BlueZ 5.4 build on Raspberry Pi
  
  sudo apt-get install xz-utils
+
Note - standard Wheezy bluez package is 4.99 and doesn't have LE support.
 +
 
 +
  sudo apt-get install xz-utils # Already got it
 
  wget https://www.kernel.org/pub/linux/bluetooth/bluez-5.4.tar.xz
 
  wget https://www.kernel.org/pub/linux/bluetooth/bluez-5.4.tar.xz
 
  xz -d bluez-5.4.tar.xz
 
  xz -d bluez-5.4.tar.xz
Line 22: Line 24:
 
  ./configure --disable-systemd
 
  ./configure --disable-systemd
 
  make
 
  make
 +
 +
-----
 +
 +
Notes:
 +
Tests use: 2014-01-07-wheezy-raspbian.zip from http://downloads.raspberrypi.org/raspbian_latest

Revision as of 11:03, 17 March 2014

In Cambridge, UK

Link to File:Circuit Symbols.svg Circuit Symbols


BlueZ 5.4 build on Raspberry Pi

Note - standard Wheezy bluez package is 4.99 and doesn't have LE support.

sudo apt-get install xz-utils # Already got it
wget https://www.kernel.org/pub/linux/bluetooth/bluez-5.4.tar.xz
xz -d bluez-5.4.tar.xz
tar xf bluez-5.4.tar
sudo apt-get install libglib2.0-dev
sudo apt-get install libdbus-1-dev libdbus-glib-1-dev
sudo apt-get install libusb-dev
sudo apt-get install libudev-dev
sudo apt-get install libical-dev
sudo apt-get install libreadline-dev
./configure --disable-systemd
make

Notes: Tests use: 2014-01-07-wheezy-raspbian.zip from http://downloads.raspberrypi.org/raspbian_latest